Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed quite a lot of 12.10 updates, was prompted to reboot, and then found that I couldn't boot.

share|improve this question
    
Since I'm not yet allowed to add comments since my low reputation I add the comment this way... I used 8128s Answer wit Boot-repair but I had to add this line before the apt-get update sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list like you see in the link he added to the answer –  Bagorolin Jul 15 at 17:53

6 Answers 6

Another thing to check is the boot order in your BIOS. I apparently had installed grub installed on all my disks (perhaps after following 8128's answer), but this broke when updating my Linux distro (Debian). Changing the first boot disk as my Linux OS fixed it.

share|improve this answer

I ran across this error upgrading to Kubuntu 13.10. I had a memory stick plugged into the USB port during the dist-upgrade. After rebooting I went straight to Grub Rescue. Unplugging the USB drive and rebooting fixed the problem.

share|improve this answer

In my case, I had downgraded to GRUBv1 and after the upgrade to 12.10 grub2 couldn't find his files (*.mod, etc...), although the grub.cfg was there.

I found a more comprehensive manual on grub rescue: https://help.ubuntu.com/community/Grub2/Troubleshooting#grub_rescue.3E-1

See also the command list at the begining of the page. Thx flute flute.

share|improve this answer

I had the exact same issue - normal.mod not found, ls of the boot partition would produce a blank line. After a week of troubleshooting to get the system to boot properly here are the steps I went through.

  1. Got a copy of SuperGrub and created a boot cd. I could now get logged back on to my system. Got a copy of BootRepair and had not luck getting the system to boot directly from the hard disk and had to keep using the CD. BootRepair did act a little strange since the Grub location and Grub options were grayed out. It did report a successful install.

  2. Hard drive was originally set up:
    sda1 ext4 root with boot
    sda2 linux swap
    sda3 ext4 used as a spare drive (holds VMs for Virtual box).

  3. Used a copy of Ubuntu 10.10 live cd. Ran gparted Install gparted to shrink the sda1 partition and created sda4 ext4 boot partition at the front of the drive and set mount point to /boot after deleting the boot directory from /. BootRepair now has options available. Installed on boot partition and can now boot from hard drive.

  4. Being curious I decided to investigate further. The boot repair log had a peculiar entry for my sda1 ext4 partition, it was reported as DOS and had a short 8 character UUID instead of the UUID reported by blkid. grub-probe reported the file system as vfat.

  5. After many other trials I cleared the first 440 bytes of sda1 partition record. Grub-probe now reports file system as ext2. Ran update-grub and the correct UUID for the sda1 partition appears.

The issue seems to be two-fold:
1. It seem to affect installations where the partition record has references to msdos.
2. grub-probe does not try to resolve mismatch issues between fs type and contents in the partition record.

share|improve this answer
up vote 18 down vote accepted

Use Boot Repair to fix your bootloader.

  1. Boot Ubuntu from a LiveCD or Live USB
  2. Connect to the internet
  3. Open a terminal, and add the Boot Repair PPA

    sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

  4. Install Boot Repair

    sudo apt-get install -y boot-repair && boot-repair

  5. Launch and use, see https://help.ubuntu.com/community/Boot-Repair#Using_Boot-Repair for more details

share|improve this answer
    
thanks, btw I used a 12.04.1 disk to fix it –  tovmeod Oct 20 '12 at 18:28
    
I had to run 3. as root (sudo su) instead of just sudoing –  David Brossard Mar 10 '13 at 20:03
    
THANK YOU!! Saved my server after a power outage. Time to buy a UPS! –  Domenic D. Jun 29 '13 at 16:20
    
used with Kubuntu 13.10 and worked. Thanks. –  David Oct 22 '13 at 13:37
    
Thanks! I've used it after install ubuntu 13.10. –  lalo Jan 12 at 1:18
  1. Type ls to get a list of partitions
  2. Enter set prefix=(hd0,msdos6)/boot/grub [you will almost certainly have to enter a different drive/partition in the brackets, you may just have to try all of those listed by ls until you find the one that works.
  3. Type insmod normal
  4. Type normal and you will get your boot prompt back!

See also: The helpful place where I found this. I doubt this will work for everyone encountering this error, but I've put it here in the hope it helps someone.

Once you've loaded Ubuntu, run sudo grub-install /dev/sda and sudo update-grub as soon as possible. This means you won't have to do that tedious process above every time you boot your machine.

share|improve this answer
7  
when I run insmod normal it again says file not found –  tovmeod Oct 19 '12 at 14:18
    
You can also use the command ls (hd0,msdos1)/ to check the contents of the partition, which would be faster if you have many partitions. –  Jonathan Oct 23 at 15:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.