Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is on my AMD FX(tm)-4100 Quad-Core Processor (according to /proc/cpuinfo) on a machine with two 4GB RAM DIMMs. BIOS shows 8GB RAM installed. Any help would be appreciated.

RAM: Extreme Performance Sector 5 G Series 8GB DDR3-1333 (PC3-1066) Enhanced Latency Dual Channel Desktop Memory Kit (Two 4GB Memory Modules)

MB: GA-78LMT-S2P Socket AM3+ 760G mATX AMD Motherboard

CPU: FX 4100 Black Edition 3.6GHz Quad-Core Socket AM3+ Boxed Processor

Here's what the software says:

$ free
             total       used       free     shared    buffers     cached
Mem:       3515100    3293656     221444          0      19260    2670352
-/+ buffers/cache:     604044    2911056
Swap:      3650556      90916    3559640

$ uname -a
Linux mythbuntu 3.2.0-30-generic #48-Ubuntu SMP Fri Aug 24 16:52:48 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

From lshw:

      description: System Memory
      physical id: 20
      slot: System board or motherboard
      size: 4GiB
         description: DIMM 1066 MHz (0.9 ns)
         product: None
         vendor: None
         physical id: 0
         serial: None
         slot: A0
         size: 2GiB
         width: 64 bits
         clock: 1066MHz (0.9ns)
         description: DIMM 1066 MHz (0.9 ns)
         product: None
         vendor: None
         physical id: 1
         serial: None
         slot: A1
         size: 2GiB
         width: 64 bits
         clock: 1066MHz (0.9ns)
share|improve this question

closed as too localized by Jorge Castro, Ringtail, hhlp, fossfreedom Nov 24 '12 at 21:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Are your eally sure you installed 2 x 4 GB RAMS and not 2 x 2 GB? Have you tried to check your ram with a RAM checker which you can start from several Linux boot CDs? Is it cheap RAM or better ones like Corsair? Is your BIOS is up to date? Any bugs reported so far? – Peterling Sep 14 '12 at 19:04
The information reported by lshw comes directly from the motherboard, has nothing to do with what the Linux kernel recognizes. You can verify this with sudo dmidecode -t 17. I advise you to review BIOS settings if you're sure the motherboard is recognizing all 8 GB, because from Ubuntu's perspective, it's only reporting 4. – roadmr Sep 14 '12 at 19:14
@roadmr "BIOS shows 8GB RAM installed." from second line of post. – hexafraction Sep 14 '12 at 19:42

I should update my post to say, "BIOS showed 8GB RAM installed." A sneaky fiend swiped the memory from this machine while I was away, and replaced it with two 2GB modules.

Thanks for the fast responses, sorry for taking your time.

share|improve this answer
Had this question faved to see how this mystery might be solved. I am still laughing. Made my day! :D – André Stannek Sep 24 '12 at 12:21
LOL... I am checking my ram's now to see if I got a friend like yours... – user12164 Sep 12 '13 at 8:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.