Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 2 desktop environments installed, i'm using the x-swat version of nvidia drivers which also got upgraded after doing "sudo apt-get dist-upgrade". Now i can only log-in using the terminal. tried "sudo service lightdm restart", that command seemed to work but gets stuck at the "*checking battery state".

to make matters worse, i can only connect to the internet by tethering my laptop with/to my android phone (sony ericsson xperia arc lt15i) and i don't know what commands to use to do same using the terminal so any solution that would require a working internet connection just makes me think that it would probably be easier just to reinstall OS and just stick to the nouveau drivers.

I have been an ubuntu user for quite some time now (since 9.04) but I must admit that i am still a noob when it comes to terminal commands.

i miss the penguin, help me!

share|improve this question
    
Please split your separate questions into individual questions. –  RolandiXor Sep 14 '12 at 17:11
add comment

1 Answer 1

Just happened to me on 12.04: interrupted an upgrade, afterwards, all uses just get a repeated greeter screen. Ctrl-Alt-F1 allowed me to login to a virtual terminal. Found no X errors in the /var/log/Xorg.0.log file, but in my home directory, found a .xsession-errors file with an odd complaint about a missing = sign on line 362 of a .c file. Traced this down to a bad openssl.cnf file. The one in /etc/ssl/openssl.cnf was fine, but the link in /usr/lib/ssl/openssl.cnf was no longer a link but a binary file. Deleted the binary file, replaced the link, and things worked again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.