Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Ubuntu starts only when I boot from my flash drive

I am a newbie on linux and dont understand many things unless given a line by line instructions. I am trying but linux does take some getting used to.

I have installed ubuntu from live usb stick. Now I cannot boot my system without the usb being plugged in. There are answers whereby certain commands need to be run. For any command that I run with sudo (prefix) the terminal asks me for a password which I dont know.

What do I do? How do I fix it such that the booting happens without usb being plugged in.

So far I have just been booting from USB. Please help a recent converted from Windows.

Thanks all

share|improve this question

marked as duplicate by Anwar Shah, jokerdino, Takkat, Mitch, Tom Brossman Sep 14 '12 at 16:31

This question was marked as an exact duplicate of an existing question.

First you should make sure that you've make a bootable USB and then install from the root.

Follow the steps below:[Backup Important data before you try!]

  1. Plugin the USB and then click try Ubuntu
  2. On the desktop click Install Ubuntu
  3. Then select the necessary steps on creating or resizing your partitions for Ubuntu. I would recommend atleast 30 GB of space for Ubuntu.
  4. Make sure that you have formatted the selected partition in "ext4" format since Linux doesn't support NTFS format.
  5. Then Click Install
  6. Verify that the installation is asking for Date, Time and then Username and Password.If not,you've done something wrong!
share|improve this answer

The password that's being asked for is your authentication password: it's the one you set during the installation process when the installer asks for your details. Also the one you use to log into your Ubuntu desktop. :)

Now, I'm a 2 month old Ubuntu convert myself and I don't come from a technical background, but it looks as though your Ubuntu bootloader (the program which is responsible for starting up your operating system) somehow got installed onto your flash drive instead of your HDD, as it should have been.

The topic that Anwar linked you to above sounds great to me. If that doesn't work, I guess you could try re-installing Ubuntu- and if you do, please go through the method described in the tutorial I'm linking you to; I used it myself, as did a friend and it worked wonders. Ubuntu 12.04 installation tutorial

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.