Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to set up a firewall on a Dell Dimension 3000 with server 12.04. I have a DCP3010 cable modem from Charter, when I plug my Win7 laptop directly into the modem I get an IP address through DHCP. I also get that when I boot into Ubuntu 12.04 desktop from the same laptop.

On the Dell, when I do "ifconfig eth0 up" the interface comes up with IPv6 address, but no IPv4. I tried using "dhclient -v eth0" and the DHCPDISCOVER requests go out, but nothing comes back. Tried changing the MTU on eth0 down to 750 but no change.

To eliminate a crossover cable requirement, I threw a Netgear switch in the middle. Again, the laptop got IP in both Win7 and 12.04 desktop modes, but the Dell still kept sending out requests with no response.

I brought the server to a corporate network and fired it up. Tada, "dhclient -v eth0" grabbed an address immediately, and I can then ping and browse, so I know the onboard NIC is working and my general configuration is good.

I'm running out of troubleshooting ideas. Any suggestions are appreciated,

Z.

share|improve this question
    
I got tired of messing around with obscure settings, so I junked the Dell, and repeated the exact process with an HP box I had lying around. Everything worked with that, so I am guessing it is some weird problem with the particular onboard NIC on the Dell. Firewall is up and running with both DHCP and DNS, and I have run 15GB of data through it in 3 days, so all is well... Z. –  ZeroPly Sep 19 '12 at 14:36
add comment

closed as too localized by fossfreedom Sep 22 '12 at 15:01

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.