Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Ubuntu won't suspend anymore, but it did upon install

I am trying to put system into suspend from terminal with the command provided by the source but i am getting the following error

raja@badfox:~/Documents$ pmi action suspend
Error org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Hal was not provided by any .service files
share|improve this question

marked as duplicate by Raja, jokerdino, Anwar Shah, Mitch, Tom Brossman Sep 14 '12 at 16:33

This question was marked as an exact duplicate of an existing question.

i got it solved by the issue . you can close the question now . – Raja Sep 14 '12 at 13:50
Tell us how you fixed it – kubahaha Sep 14 '12 at 14:49
up vote 0 down vote accepted

@kubahaha & other Friends Ok this is how i have fixed the issue ,

Open your terminal and do this

sudo apt-get install hal 

then do as pmi action suspend

Issue won't arise again . Hope that helps .

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.