Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

No matter how much advice I follow, I still cannot get any audio to come out through my HDMI connection. I've tried downloading the latest proprietary FGLRX graphics drivers, and I've also gone into /etc/default/grub and altered

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 

into this

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

But still I cannot get any sound nor can I get HDMI sound output to show up in Sound Settings or Pulse Audio Volume Control. I can get video to show up just fine on my monitor through HDMI so I'm sure this problem is fixable! I know this is an old problem with Ubuntu, but any new strategies into the problem would be much appreciated.

With that being said, here are some of my specs:

  • Ubuntu 12.04 LTS
  • AMD Radeon HD 7520G
share|improve this question
    
Never mind people. The upgrade to 12.10 fixed it (as long as I use the proprietary fglrx drivers instead of the open source one). –  Matt Robinson Oct 24 '12 at 15:44
add comment

2 Answers 2

I had the same problem. Then I read this and did the trick, I hope it works for you too: Open the terminal and:

sudo apt-get install fglrx

After a reboot and selecting the correct output in "System Settings > Sound > Output" everything worked like a charm. Let's see whether it stays that way...

share|improve this answer
add comment

Adding radeon.audio=1 to the splash in ubuntu 12.04 and 12.10 do not seem to work although 13.04 it works and audio plays well, this may be due to the new 3.8 kernel and if so you can install it by going here:

http://www.upubuntu.com/2013/03/install-linux-kernel-384-in-ubuntulinux.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.