Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an ISO (created from an NRG with nrg2iso) backup of a beloved game from my youth: Dark Reign: Rise of the Shadowhand (1998). I with to relive those better times by listening to game's soundtrack.

Is there a way for me to mount said ISO in such a way that I can rip the audio tracks into mp3 files? I ask because although I can successfully mount the ISO, ripit / abcde report no cd inserted.

How I mounted the ISO:

sudo mount -t iso9660 -o loop iso.iso /media/ISO

Alternatively is there another way to recover audio from ISO / NRG images?


I was able to mount the NRG version of my backup in a way that ripit recognized using gCDEmu. ripit failed to rip, however, barfing on the first track - which is most definitely a data track. Is there a way to make ripit ignore the first track?

share|improve this question
How do you "successfully mount the ISO"? What steps do you take to mount it? Also, have you tried the Sound Juicer (package name sound-juicer -- you also need gstreamer0.10-plugins-ugly package to rip as mp3)? – medigeek Sep 13 '12 at 21:29
He @medigeek, I've updated my question with details on how I mounted the iso. I haven't tried sound-juicer, looking at it now. – Michael Robinson Sep 13 '12 at 21:35
I see sound-juicer is a GUI app - I'm restricted to CLI currently. – Michael Robinson Sep 13 '12 at 21:36
sound-juicer failed, even when the NRG was mounted with gCDEmu – Michael Robinson Sep 14 '12 at 0:02
Are you able to play the mounted music cd at all? Is it a Mixed cd? Try converting the nrg format to iso first, using a windows program like ultraiso (you need windows). Also, I don't understand, you mentioned you managed to make it work using gcdemu which is a gtk application if I'm not mistaken and you ask for a client app -- did you mean cdemu the client program? Why do you need cli only anyway? – medigeek Sep 14 '12 at 13:27

Try this:

sudo mount -o loop ~/iso.iso /media/cdrom0

Then try ripit --device /media/cdrom0

share|improve this answer
Thanks for this - ripit still asks me to insert an audio CD: Please insert an audio CD! – Michael Robinson Sep 13 '12 at 21:53
I was able to mount it in a way that ripit recognized with gCDEmu, but ripping failed. I've updated my question with more details. – Michael Robinson Sep 13 '12 at 23:59

You are mounting it correctly. You actually shouldn't need to "rip" the cd, and it will probably fail anyway, since it is a data CD. There should be .wav or .mp3 files on the cd. Just look for them after mounting. If they are .wav's you can use the following to easily convert them to mp3s.

lame -V2 input.wav output.mp3

More info can be found with:

lame --help

If it is a hybrid cd, as izx mentioned, then you can simply skip the first track with ripit, like this:

ripit --device /media/cdrom 2-

This will rip track 2+.

share|improve this answer
This is incorrect. There was a time when some games used to come with the soundtrack on a "hybrid data/audio" CD -- mid-1990s? To provide high quality sound. Track 1 was data, IIRC. One I can vividly remember is "Monster Truck Madness" (c. 1996). – izx Sep 13 '12 at 23:30
The backup iso I have is Dark Reign: Rise of the Shadowhand, released 1998. I desire to feel the gentle caress of its glorious soundtrack once more. The nrg/iso files I have (iso created by nrg2iso) are ~540 MB, only ~200 MB of data on it when viewed in terminal / nautilus. – Michael Robinson Sep 13 '12 at 23:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.