Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is my first posting here, so please be gentle. I am having a problem installing Matlab 2012a (32-bit) in Ubuntu 12.04 LTS. I have trawled around the web and have seen similar problems reported, but I cannot seem to get around the issue, my problem is very similar to the one reported here:

http://www.mathworks.in/matlabcentral/answers/42988-installing-matlab-2012a-in-ubuntu-12-04-java-problem

Except that I get an error message that refers to the java module located in glnx86: /tmp/mathworks_2247/sys/java/jre/glnx86/jre rather than glnxa64.

Here is my problem.

I have installed the Matlab installation software here:

/home/usr/Desktop/Matlab_installation

I first used chmod +x install to convert the install file to an executable file. I then used the sudo ./install -v command to install matlab. Here is the output:

sudo ./install -v
[sudo] password for usr: 
Preparing installation files ...
->  DVD                 = /home/usr/Desktop/Matlab_installation

->  ARCH                = glnx86

->  DISPLAY             = :0

->  TESTONLY            = 0

->  JRE_LOC             = /tmp/mathworks_2247/sys/java/jre/glnx86/jre

->  LD_LIBRARY_PATH     = /tmp/mathworks_2247/bin/glnx86

Command to run:
/tmp/mathworks_2247/sys/java/jre/glnx86/jre/bin/java  -splash:"/home/usr/Desktop/Matlab_installation/java/splash.png" -Djava.ext.dirs=/tmp/mathworks_2247/sys/java/jre/glnx86/jre/lib/ext:/tmp/mathworks_2247/java/jar:/tmp/mathworks_2247/java/jarext:/tmp/mathworks_2247/java/jarext/axis2/:/tmp/mathworks_2247/java/jarext/guice/:/tmp/mathworks_2247/java/jarext/webservices/ com/mathworks/professionalinstaller/Launcher -root "/home/usr/Desktop/Matlab_installation" -tmpdir "/tmp/mathworks_2247" 

Installing ...
/tmp/mathworks_2247/sys/java/jre/glnx86/jre/bin/java: error while loading shared libraries: libjli.so: cannot open shared object file: No such file or directory
Finished

I then attempted the command chmod +x /sys/java/jre/glnx86/jre/java to convert Matlab's Java to an executable.

I have tried this in a number of ways from navigating through the directory structure in the terminal window (and converting) to using the point and click navigation system and right clicking on Java and converting it to an executable. All of these work fine, the file appears as an executable file, here is how the java file appears using ls -l:

-rwxrwxr-x 1 usr usr  47308 Sep 13 13:23 java

it is clearly listed as executable. However, I continue to get the error message:

Installing ...
/tmp/mathworks_2387/sys/java/jre/glnx86/jre/bin/java: error while loading shared libraries: libjli.so: cannot open shared object file: No such file or directory
Finished

when using sudo ./install. What am I doing wrong? I have tried systematically converting the java @/glnx86/jre/bin/java to an executable (and back again) without success. Notice that in contrast to previous posts I seem to be having an issue with the glnx86 java rather than the glnxa64, could this be the source of the problem?

Any help would be gratefully received. regards

share|improve this question
    
Is your computer a 32 or 64-bit architecture? And, your Ubuntu version? –  Yamaneko Sep 13 '12 at 18:21
    
Also, add codetags or <pre></pre> to improve the readability of your question. –  Yamaneko Sep 13 '12 at 18:22
    
The computer is 32 bit architecture –  Mark Emmerson Sep 14 '12 at 14:21
    
I wanted to wait to check on machine, all I can find is that the version of Ubuntu is 12.04 LTS –  Mark Emmerson Sep 17 '12 at 12:08
add comment

2 Answers 2

I use matlab too, if this problem with LD_LIBRARY_PATH, maybe this can help u.

export LD_LIBRARY_PATH="/usr/local/MATLAB/R2011a/runtime/glnx86:/usr/local/MATLAB/R2011a/bin/glnx86:/usr/local/MATLAB/R2011a/sys/java/jre/glnx86/jre/lib/i386/client":$LD_LIBRARY_PATH

export LD_LIBRARY_PATH and reinstall,

share|improve this answer
    
Sorry Panji, is this something you would try after you have managed to install Matlab, I dont even seem to be able to get that far. Have I misunderstood something in your post? –  Mark Emmerson Sep 17 '12 at 12:09
add comment

I also faced the same issue. You need to add javadir to the install command.

./install -v -javadir <location of jre in your machine>
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.