Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

KDE Telepathy keeps getting in the way every time I try to use Empathy from the messaging menu. If I get a message, it opens in the KDE telepathy UI instead of in Empathy. This is rather frustrating as it causes a delay before it opens, and is not integrated with Empathy.

How can I stop this from happening? This still happens in 12.10 and I've had to remove the kde-telepathy packages. Is there a solution?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

I figured out how to do this (Ubuntu 12.10):

Edit /usr/share/dbus-1/services/org.freedesktop.Telepathy.Client.KTp.TextUi.service to comment out (or remove) the link to ktp-text-ui and use Empathy instead.

In the end, the service file will look like this:

[D-BUS Service]
Name=org.freedesktop.Telepathy.Client.KTp.TextUi
# Exec=/usr/lib/kde4/libexec/ktp-text-ui
Exec=/usr/lib/empathy/empathy-chat

After this, I figured I had to restart dbus, but doing a

sudo service dbus restart

is evidently a bad idea, since it locks up everything.

So I suppose you have to log out and log back in (or reboot, which is what I ended up having to do).

share|improve this answer
add comment

There's a bug report on this issue here: https://bugs.launchpad.net/ubuntu/+source/ktp-text-ui/+bug/951104 There's a proposed solution on the last line, but I have to confess that I'm not entirely sure how to go about defining a preferred handler on dbus. (Since it's easy enough to remove the kde-telepathy packages without affecting the rest of KDE and I don't need two messaging clients, I just went with that option instead.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.