Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everything went on well. Today morning when I rebooted my workstation, I was appalled by the grub rescue screen that appeared on boot up. I could not guess what could be the reason for this. Trying to find out a solution, I googled and browsed several sites and performed the following commands from a live cd.

sudo mount /dev/sda2 /mnt
sudo grub-install /dev/sda /mnt

I later recognized that I should have installed grub in sda1 and not in sda2. sda2 is my ubuntu partition with all my data. On reboot, I was further taken aback by appearance of a grub prompt. On googling again, I was instructed to run find command in grub. I then got this error.

grub>unknown command find

Not knowing what to do, I booted again using a live CD. I felt awwww when I saw my 2 TB file system showing only five folders leaving out the main home folder which contained all the users and the data. I assumed that I have made a mistake by installing grub on /dev/sda2 and it has replaced ubuntu and the data. I then tried several solutions given online. Like I tried to recover using boot-repair, followed this link http://www.dedoimedo.com/computers/grub-2.html#mozTocId842078 and tried to chroot. On giving chroot I get

chroot: cannot run command /bin/bash no such file or directory

I have also pasted the bootscriptinfo results for your reference. http://paste.ubuntu.com/1202960/ Kindly help me out. Is my presumption correct ? Has grub replaced the ubuntu partition and all its data ? How could I bring my machine back to its original state ?

share|improve this question
1  
You need to install grub on /dev/sda. Follow the steps given here: askubuntu.com/questions/182855/no-boot-selection-screen/…. –  green7 Sep 13 '12 at 16:46
    
But bootscriptinfo says it is already installed on /dev/sda –  Jaroslav Bucko Sep 13 '12 at 16:52
    
Is der any way of getting out of this issue ? –  Karthikn Sep 14 '12 at 1:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.