Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I disabled Capslock a while ago when I finally upgraded to 10.04 (via System ➜ Preferences ➜Keyboard ➜ Layout ➜ Options). Now, I simply want to set it to Make CapsLock an additional ESC. But Ubuntu seems to hate Capslock so much, that, as soon as I close the dialog, it resets it to disabled.

My best guess is, that it can't write the setting due to some ownership issues, but I couldn't figure out where the setting is actually stored.

share|improve this question
    
What you want to do??Do you want to change your capslock to Esc?? –  karthick87 Dec 24 '10 at 17:49
    
Uh yes? Doesn't the question already state that? If not, them I'm sorry, I disabled it via "Keyboard -> Layout -> Options" but now I can't change the setting for Capslock in that dialog anymore, the settings for all the other keys still works though. –  Ivo Wetzel Dec 24 '10 at 17:52
    
awesome -- didn't know that there was a method to change this via the GUI. Something new to test for future alpha/beta releases.... –  belacq Feb 25 '11 at 16:41

1 Answer 1

up vote 4 down vote accepted

The setting is stored in /desktop/gnome/peripherals/keyboard/kbd/options in the alt textGConf configuration database.

Make sure that key is set correctly:

  • Hit Alt+F2 and enter gconf-editor in the dialog window and click Run,

    alt text

  • Navigate to /desktop/gnome/peripherals/keyboard/kbd/options,

    alt text

  • Make sure there is the item caps:escape (as shown in the previous screenshot)
    and not caps:none.

share|improve this answer
1  
Thx, that did the job (way less reaching for ESC in VIM now). I tried it via the GUI afterwards again, but it seems that this thing is bugged it always sets it to none not matter what is in gconf. Anyways I'm fine with setting it via gconf directly :) –  Ivo Wetzel Dec 24 '10 at 23:42
    
@Ivo Try setting it correctly in GConf and then setting it correctly via the GUI and then close the GUI. That might make it stay "in sync". –  Alvin Row Dec 24 '10 at 23:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.