Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Nvidia GeForce GT 500 series card, and cannot install the video driver needed:

  • Additional drivers doesn't find any
  • Downloading and installing the driver from the Nvidia website doesn't work
  • CTRL+ALT+F1 gives an error ("no native mode, forcing panel scaling)
  • my monitor stays flickering
share|improve this question
    
Hi Brent, a couple of questions: 1. What version of Ubuntu are you using, and how is the video card connected to the monitor, via HDMI, VGA, S-Video... –  Luis Alvarado Sep 13 '12 at 14:47

3 Answers 3

What I recommend and it happen something similar to me with the GTX 560TI but instead of flickering only it also included some puzzle effect where pieces of the monitor where not in order, so for example the top part was in the middle, the bottom part on top and son on. Took me a little while to get used to it while I worked on a solution. So this is what I did to solve it:

I booted the PC as I normally would (Not proprietary drivers installed yet) but it "froze" or at least that what the video said to me before entering to the Desktop. Not even lightdm appeared. So I booted again but this time left SHIFT pressed so the GRUB Menu would show. I then proceeded to select Recovery Mode which continued booting correctly until the Recovery Menu appeared.

In the recovery menu I selected failsafeX.

Now here is where it starts to get tricky. With the GT 220 and GT 440 I did not have any problems booting into the Desktop after selecting failsafeX but with the 560 the failsafeX gave me an error "The system is running in low-graphics mode" and stayed there forever. What I did in this case is that from there I went to the terminal (CTRL+ALT+F1) and typed (I had previously install aptitude but it works the same way with apt-get):

sudo aptitude install nvidia-current - If you haven't install it yet
sudo aptitude reinstall nvidia-current - If you have already installed it

For other cases see this answer for details and follow the links there to help you along the way.

It downloaded and installed the drivers correctly. Same thing if you use apt-get:

sudo apt-get install nvidia-current

Remember that in the case you get an error AFTER selecting failsafeX from the recovery mode, pressed CTRL+ALT+F1, typed your user/pass and do the nvidia-current package installation from there.

After rebooting all problems should be solved. I have already tested the Additional Drivers and after finishing downloading the package it gave an error. I also went to software center and synaptic to try to install them, with the same result. The only way was either using failsafeX or the workaround about changing to the tty1 terminal and doing it via command line.

I also need to add that I do not recommend downloading the Drivers from the Nvidia site since they:

  • Might create additional problems with Ubuntu
  • Are not updated automatically
  • Are not tested thoroughly in Ubuntu

Always use the nvidia-current package or the nvidia-current-updates one. This are tested and approved already for the Ubuntu version you are using and will give less errors and incompatibility bugs.

share|improve this answer

It could've been something as simple as refresh rate. See what your monitor supports and see if your software is using the correct rate.

share|improve this answer

It is fixed using the Nvidia X server software.

share|improve this answer
1  
This does not provide a sufficient answer to the question. Try to add more information, and / or examples. –  Mitch Sep 15 '12 at 7:48
    
@Mitch You're quite right that this answer should be expanded to provide more details. However, since this is by the OP, indicating that he has solved the original problem, it should definitely not be deleted, and it's much better for it to have been posted than not. Brent: Unless you are still looking for another answer, please mark this (i.e., your own answer) as the accepted answer by clicking the green check mark to the left of it. But please consider marking Luis Alvarado's answer as the accepted answer instead, if that's really what enabled you to solve the problem. –  Eliah Kagan Oct 1 '12 at 21:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.