Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After save config in NetworkManager, I put in terminal command: "ifconfig". The changes saved from NetworkManager does not applying, and configuration interface is empty.

I try for DHCP AND manual (static) configuration.

I configured connection manually by ifconfig command, but NetworkManager overwrite by empty configuration NetworkManager.

I copied NetworkManager configuration from working copy ubuntu 10.04 to ubuntu 12.04.01 and still don't save configuration, on connection eth0.

Ubuntu 12.04.01 Installed from USB, In previously Ubuntu version 10.04 work fine.

share|improve this question
1  
please provide some more information. –  green7 Sep 13 '12 at 12:22
    
I added more information –  Arek Sep 13 '12 at 13:44
    
OK. So, did you try to change DHCP to manual? But it still shows the same IP in ifconfig? –  green7 Sep 13 '12 at 16:44
    
exactly. Is the NetworkManager save any logs about working or exceptions or errors maybe this help ? –  Arek Sep 13 '12 at 18:01
    
try restarting your network: sudo /etc/init.d/networking restart and check again. –  green7 Sep 13 '12 at 19:25

1 Answer 1

Restart Your Network

It might be the case that you didn't restart your network. To do so, open a terminal (Ctrl+Alt+T) and run the following command:

sudo /etc/init.d/networking restart

If this doesn't work, try the next option.

Editing /etc/network/interfaces File

  • Open a terminal (Ctrl+Alt+T).

  • Open the /etc/network/interfaces file.

sudo vim /etc/network/interfaces
  • Find and remove the following entry:
iface eth0 inet dhcp
  • Assuming the required settings are as follows:

    • Host IP address 192.168.1.100
    • Netmask: 255.255.255.0
    • Network ID: 192.168.1.0
    • Broadcast IP: 192.168.1.255
    • Gateway/Router IP: 192.168.1.254
    • DNS Server: 192.168.1.254

Add the new network settings to the file:

iface eth0 inet static
address 192.168.1.100
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.254
  • Save and close the file. Restart the network:
sudo /etc/init.d/networking restart
  • Now, we need to define the new DNS servers. Open the file /etc/resolv.conf:
sudo vim /etc/resolv.conf
  • You need to remove old DNS server assigned by DHCP server:
search myisp.com
nameserver 192.168.1.254
nameserver 202.54.1.20
nameserver 202.54.1.30
  • Save and close the file.

Source: http://www.cyberciti.biz/tips/howto-ubuntu-linux-convert-dhcp-network-configuration-to-static-ip-configuration.html.

share|improve this answer
    
After edit /etc/network/interfaces and /etc/init.d/networking restart, the config of eth0 ifconfig still empty, ifconfig and syslog may help: pastebin.com/pPF9vuvQ –  Arek Sep 14 '12 at 8:14
    
it seems that the IP address you're trying to assign is not available or there is some problem with your network. –  green7 Sep 14 '12 at 8:18
    
please look at pastebin.com/pPF9vuvQ syslog there is .."ADDRCONF(NETDEV_UP): eth0: link is not ready".. My network work ok, I have identical network configuration on ubuntu 10.04 and it's working –  Arek Sep 14 '12 at 8:21
    
This link suggests checking the cables. –  green7 Sep 14 '12 at 8:23
    
Hm cables it's ok, becouse now I post this comment from the same computer but from 10.04, Installation of 12.04 is on other partition. –  Arek Sep 14 '12 at 8:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.