Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed it by using a load of unallocated space on a completely separate hard drive than the one Windows is installed to.

When I choose Windows on the boot menu I get this:

'Invalid EFI path'

Any idea why this is?

EDIT: Here is information from boot info script.

I think it might be because I have more than 4 partitions on the drive? Although I am not sure what the one labelled as 'unknown' is at all.

share|improve this question
Which boot menu are you using? If you are selecting the Windows entry in Grub[2] then try switching the boot order in your UEFI/BIOS and see if Windows boots on its own. – Huckle Oct 9 '12 at 2:48
  1. If you using EFI, install grub-efi: apt-get install grub-efi
  2. Use "Separate /efi" option of Boot-Repair.
  3. Then force your BIOS to boot into Grub EFI partition

This works for me every time. Good luck!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.