Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have Ubuntu 12.04.1 installed alongside Mac OS X 10.4.11 on my iMac G5 with powerpc architecture.

I only have one internal hard drive and I created a small 5 GB partition on it and formatted it to fat32 with GParted in Linux, but OS X won't recognize it, Disk Utility sees it as mere empty space.

I also tried to format it as NTFS and install ntfs-3g on Mac OS X as a plugin toread and write to NTFS but the same thing happens, the partition is seenas mere empty space and thus can't be mounted. I can't even partition anything from Disk Utility because it says that this disk drive is the startup boot drive.

Any ideas?

share|improve this question
add comment

1 Answer 1

You should be able to read the MAC OSX partition from Ubuntu 12.04 without any modifications. You might have to mount the partition, although I would expect Ubuntu to automatically mount it read only, so you just have to find the partition in the file browser and open it.

OSX by default uses journaled HFS+ as it's file system. Ubuntus kernel has support for this file system built in. If you want read/write access to the OSX partition, you have to disable journaling in OSX. Here are some guides with more details:

https://help.ubuntu.com/community/hfsplus

http://manpages.ubuntu.com/manpages/intrepid/man7/hfsplus.7.html

share|improve this answer
    
I know I can read and write to HFS+, but I'm having file permission problems so I wanted to have a shared fat32 partition through which I could exchange files without permission problems. I just ran fdisk -l in Terminal, and the fat32 partition I created with GParted shows up as a linux native partition Apple_UNIX_SVR2. Shouldn't it be shown as fat32 instead? The same thing shows up in Disk Utility, that Apple_UNIX_SVR2 thing. –  user89004 Sep 13 '12 at 7:02
    
Is it normal to receive a Bad super block magic number missing error in Mac OS X when running fsck with -ly? I run fsck from Ubuntu on that Mac HFS+ partition and it says all is fine. I just wanted to be sure of this. It's probably because of the boot loader, isn't it? –  user89004 Sep 13 '12 at 7:16
    
I would not recommend disabling journaling, and I do not recommend writing to the OSX system partition from a different OS. If you want to read and write to some files from both OSs, you should create a separate partition for this purpose. Non-journaled HFS+ would work as a file system, FAT 32 should also work. –  Sandy8086 Sep 13 '12 at 7:25
    
Well, that's what I said, FAT32 DOESN'T work for me as Mac OS X fails to recognize it. Disk Utility says it's Apple_UNIX_SVR2 instead of Fat32. I partitioned it with GParted under Ubuntu. I want to do this so I can get rid of file permission errors, as I can't access my Home folder on my Mac partition from Ubuntu. Is there any other way around this without screwing up files for the Mac partition? –  user89004 Sep 13 '12 at 7:43
    
Well, unjournaled HFS+ works fine for both OSes, but now I'm worried about the FAT32 and NTFS partitioning capabilities of GParted. Is there something wrong iwth it since fdis -l sees both partitions that GParted makes as being LINUX native Apple_UNIX_SVR2? –  user89004 Sep 13 '12 at 8:07
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.