Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been struggling hard since i have installed Ubuntu 10.10 but it has been difficult for me to get my wifi working.

So here is what i tried.

  • First i checked whether i have the driver using the ifconfig command and it shows the wireless lan driver as wlan0.

  • Next, i tried the command iwlist wlan0 scanning by becoming the root which gave me the output as no scan results.

  • Next, i visited this link https://help.ubuntu.com/community/WifiDocs/Driver/Atheros to see as to what problem my laptop may have. I do own have an ath5k chipset. And as i followed the instructions in the above link in one of the blacklist-ath_pci.conf file had this written in it.

For some Atheros 5K RF MACs, the madwifi driver loads buts fails to correctly initialize the hardware, leaving it in a state from which ath5k cannot recover. To prevent this condition, stop madwifi from loading by default. Use Jockey to select one driver or the other. (Ubuntu: #315056, #323830

I am not that good at Linux but i have given it a try. I am desperate to have my wifi working and i would be glad if this community could help.

  • ADDED: If anyone would like to know as to what drivers i am using this is the output.
network
   description: Wireless interface
   product: AR2413 802.11bg NIC
   vendor: Atheros Communications Inc.
   physical id: 3
   bus info: pci@0000:0a:03.0
   logical name: wlan0
   version: 01
   serial: 00:19:7d:d3:0c:fd
   width: 32 bits
   clock: 33MHz
   capabilities: pm bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath5k driverversion=2.6.35-24-generic firmware=N/A 
     latency=168 link=no
     maxlatency=28 mingnt=10 multicast=yes wireless=IEEE 802.11bg
   resources: irq:18 memory:d0000000-d000ffff

Some more information and output as to what i have done.

lsmod | grep ath
ath5k                 130083  0 
mac80211              231541  1 ath5k
ath                     8153  1 ath5k
cfg80211              144470  3 ath5k,mac80211,ath
led_class               2633  1 ath5k

alt text

share|improve this question
add comment

7 Answers

I had the same problem. Almost took me a month to set it straight. Mine is an ATHEROS AR5007EG.

First I tried ndisgtk (NDISWRAPPER), ... it worked but was very fuzzy. It used to show all available Wireless networks but connecting to it took a lot of time.

Growing tired of waiting I gave mad wifi a try. It worked ... the only downside was that it needs reinstallation for each kernel upgrade.

Here are the steps:

  1. First and the most important bit is undoing all that you have done so far ... specially all blacklists you have added.

  2. Uninstall the mad wifi drivers already installed .. follow this link under the header "Removing old modules".

  3. Once all modules are removed use this link to follow Dr. P.J. Kurian's method listed under the heading "Method Using madwifi and ath_pci" ... follow all the steps mentioned.

That should do it :)

The secret is being patient.

Hope this helps.

share|improve this answer
    
Here is an article I wrote when NDISWRAPPER worked for me : rahul27.co.cc/content/wireless-and-ubuntu-1010 –  rahul27 Feb 8 '11 at 7:19
add comment

If the scan doesn't show anything, maybe there are just no available wireless network. Did you try connecting any other devices? Sorry if this is a bit obvious.

share|improve this answer
    
Yes there are wireless networks –  user5929 Dec 24 '10 at 14:26
    
because, when i see in my mobile it shows some wifi access points, and moreover wifi is enabled in my house –  user5929 Dec 24 '10 at 14:27
add comment

Maybe there's conflict between two different drivers for the same hardware. I don't know about you wifi hardware, but if there's conflict you should blacklist one of the driver, adding "blacklist nameofthedriver" in the last line of this file /etc/modprobe.d/blacklist.conf .

share|improve this answer
    
No it doesn't work. I did try what you mentioned –  user5929 Dec 25 '10 at 16:40
add comment

You could try the madwifi driver. For me it was available by running:

sudo jockey-gtk

from a terminal

share|improve this answer
add comment

You could try installing LBM: sudo apt-get install linux-backports-modules-wireless-maverick-generic

These are wireless drivers from later kernels backported to the maverick kernel.

share|improve this answer
add comment

One quick way to see if this is a problem with the configuration of your laptop would be to boot from an Ubuntu LiveCD and see if it can detect the ath5k wifi and connect to an access point.

Even so, if you have wlan0, that means you have the hardware driver installed (unless you have other wifi devices?) already. lsmod|grep ath5k also means you have the driver installed correctly.

At that point, I'd check to see if it could be a problem with wpa_supplicant (handles encrypted wifi). You can check that by trying to connect to an unencrypted/open wifi access point.

I have an Atheros AR5212 in my laptop and I have been totally unable to connect to some specific wifi access point models. So, try to connect to two different models of unencrypted/open access points to make sure it's not specific to your available access point.

Your link to the "ath5k cannot recover" bugs could be the cause, but I don't think Ubuntu uses madwifi by default? I could be wrong.

share|improve this answer
add comment

Is your PC a laptop? Is there a hardware button you must push/press or move over to turn on the wifi radio?

share|improve this answer
    
@dooroo: yeah i have a laptop. i have done those things. –  user5929 Dec 24 '10 at 14:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.