Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I had installed VLC 1.1.4 in ubuntu 10.04 via a PPA. After I installed it, I have not been able to view subtitles after loading it. It appears as a rectangle in place of text.

How can I fix this?

share|improve this question
Do subtitles work with the official repository version of VLC? I have never had any problems with subtitles in VLC. – dv3500ea Dec 24 '10 at 13:16

3 Answers 3

Is it a single rectangle where the text should be or a series of letter sized rectangles?

If it is multiple rectangles then you probably are missing a font with the proper glyphs for the language you are trying to view. Look in Preferences ➔ Subtitles & OSD and report the Encoding and Font Selected.

For example if ဆဌဗရယမဝဪ appears as rectanlges and not the prettiest letterforms on the planet (Mayanmar) then you don't have Unicode support in your font. (I don't know Mayanmar so those are random glyphs, my apologies if they say something rude.)

share|improve this answer

The problem might be with the encoding of the subtitle file. Try opening the file and see if you can see the text in the text editor(you definitely should), if you don't, then get a different subtitle file.

If you are able to see, copy all text to clipboard, and save it in a new file as a plain text file with the extension ".srt" and replace the original file. Lock and load!

For VLC to pick up the subtitles automatically, make sure that the video file and the srt file have the same name.

share|improve this answer
Worked for me, I just copied the contents to a new empty plain UTF-8 file and got rid of the problem plus some 2 kB... – Rodrigo Aug 27 at 0:54

In my case I saw question marks instead of the real letters. Specifying the correct encoding in the Preferences->Subtitles&OSD did not help. I also saw suspicious text in the terminal (ubuntu):

[0x7f709c05dd50] subsdec decoder error: failed to convert subtitle encoding.
Try manually setting a character-encoding before you open the file.
Bus::open: Can not get ibus-daemon's address. 
IBusInputContext::createInputContext: no connection to ibus-daemon 
Warning: call to rand()

After I removed the ibus libraries, the letters appeared properly:

apt-get remove ibus ibus-gtk ibus-m17n  ibus-pinyin ibus-pinyin-db-android  ibus-qt4 ibus-table libibus-qt1 libibus2

I filed bug report on that over here.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.