Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to Ubuntu 12.04 from 10.04. My laptop has two hard disks and when I mount the second disk, I no longer have any control over the file permissions (even in su mode). So none of the software I have installed on that disk works anymore. How do I fix this?

share|improve this question
    
Could you give more details, please? 1) How do you mount it? 2) What are the options in your /etc/fstab ? 3) Please give us the output when you run the 'mount' command –  Sentry Sep 12 '12 at 22:04
    
here is what is in my /etc/fstab file: –  Steven Sep 12 '12 at 22:08
    
1) I mount it by just clicking on the icon in a standard file folder (as I did in version 10.04) –  Steven Sep 12 '12 at 22:14
    
2) here is the /etc/fstab file : # /etc/fstab: static file system information. # # Use 'blkid -o value -s UUID' to print the universally unique identifier # for a device; this may be used with UUID= as a more robust way to name # devices that works even if disks are added and removed. See fstab(5). # # <file system> <mount point> <type> <options> <dump> <pass> proc /proc proc nodev,noexec,nosuid 0 0 # / was on /dev/sdb4 during installation UUID=c43e384a-0675-4b88-84b7-3eb8ecc1a575 / ext4 errors=remount-ro 0 1 –  Steven Sep 12 '12 at 22:14
    
# /boot was on /dev/sdb2 during installation UUID=4b714b5a-2cfd-4752-b7bc-8059e16a31fd /boot ext4 defaults 0 2 # swap was on /dev/sda2 during installation UUID=e6c07b63-5621-4c2f-a8c1-4cb72ad36960 none swap sw 0 0 –  Steven Sep 12 '12 at 22:15
show 2 more comments

1 Answer 1

Okay, from what I read there you have /dev/sdb4 which is mounted as your root filesystem. You also have /dev/sda2 which is your swap. Otherwise there seem to be no partitions on your hard disk. Which is most likely part of the issue. Please open a terminal, type "sudo blkid" and post the output here. If you don't know how to use a terminal, use google.

Please also use pastebin.com if you want to paste code here. The idea is, that you go there, paste your code, get a link, get back here and paste the link. Keeps everything clean and readable.

Cheers

share|improve this answer
    
OK from what I gather the problem is with how 12.04 mounts an ntsf drive versus the way 10.04 did. In 10.04 the drive mounted such that the permissions were made and defined like a native linux environment (i.e., folders got the rwx and files inherently got the rw permissions.. but the user was allowed to make files executable with the chmod command). The new 12.04 does not mount in this way. If I modify the /etc/fstab file to have the ntsf drive with the option "umask=000" the scripts and other software I have work, but this option makes every file executable, which is not desirable. –  Steven Sep 12 '12 at 23:25
    
Is there a combination of umask=###,fmask=###,dmask=### that will make the drive behave like a standard linux environment? –  Steven Sep 12 '12 at 23:25
    
:) well, since I've stopped using Windows about ten years ago, I have no experience whatsoever in this area. Good luck! –  strom Sep 12 '12 at 23:28
    
Yeah I never use windows either... I have a windows partition (that is rarely used) that, at the time, required me to have my other drive be ntsf so that I could write to it. –  Steven Sep 12 '12 at 23:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.