Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Lenovo 3000N100 which has WiFi card/drives that are not working.

I have tested the card with Windows and it works. Tried un-installing the card in 12.04.1 and re-installing it even with a reboot and still no good.

Can anyone give me some help on this?

share|improve this question

in case you are running BCM4311 (to check run lspci --vvnn | grep 14e4)

try this:

(source bkratz (ubuntuforums))

sudo apt-get update 
sudo apt-get install linux-firmware-nonfree 
sudo modprobe -r b43 && sudo modprobe b43

works fine for me:)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.