Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every time I am try to install Adobe Flash plug-in via Ubuntu Software center, I get the error message:

Package dependencies cannot be resolved

I tried various commands in the terminal but I couldn't fix the problem.

share|improve this question
Can you include the detailed error message? – Mitch Sep 12 '12 at 17:31

Try this. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo dpkg --configure -a       
sudo apt-get install -f
sudo apt-get update

And then try installing again.

If the above doesn't help, you can always install Adobe flash using:

sudo apt-add-repository "deb $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install flashplugin-installer

Source:Install Adobe Flash

share|improve this answer
Thx for the reply :) The first doesn't help but with the second commands it worked. thx a lot – alex Sep 12 '12 at 21:07
@alex If this answered your question, you may mark this answer as accepted. – Mitch Sep 13 '12 at 5:04

Sounds like a repository mismatch. I've been dealing with broken packages and dependencies ever since the last Ubuntu upgrade, last night.

Which repository location are you using?

I had mine set for a mirror in Brazil (which is close to where I live). Only after I switched back to the Main repo stuff got back to normal.

apt-get update
apt-get clean
apt-get autoclean
apt-get install -f
apt-get upgrade
share|improve this answer
thx for the reply :) – alex Sep 12 '12 at 21:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.