Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I tried to update my Ubuntu through the update manager I received an error about some unknown resource. so i tried doing it from the terminal with

sudo apt-get update

but all I got is:

0% [Connecting to 192.168.43.1

repeating itself... and when I press Enter it shows:

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/precise-security/universe/i18n/Translation-en  Unable to connect to 192.168.43.1:8000:

E: Some index files failed to download. They have been ignored, or old ones used instead.

How can I get this to work?

share|improve this question
    
Do u have INTERNET. Open firefox and see? –  blade19899 Sep 12 '12 at 14:45
    
see what? ive been trying to find an answer for two days.... all i got is that it might bu cused by some mobile network wich i dont use... –  Alex R Sep 12 '12 at 15:40
    
This definitely looks like a network or proxy issue. 192.168.43.1 is not a public Ubuntu repository (addresses beginning 192.168 are private network addresses behind people's routers, it could be your one of your own computers). Can you ping archive.ubuntu.com? If so, from the output of ping what address does it give you? Have you set up proxies anywhere? –  John S Gruber Sep 12 '12 at 19:23
add comment

1 Answer

It looks like apt is configured to use a proxy since 192.168.*.* is a private IP range.

Use the next command to list all files in /etc/apt that contains 192.168.43.1:

grep -rlF 192.168.43.1 /etc/apt

It possibly prints /etc/apt/apt.conf. Open that file. Find a line that contains the proxy configuration and remove it:

Acquire::http::Proxy "http://192.168.43.1:8000/";

Save it and try updating again:

sudo apt-get update
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.