Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 and Awesome window manager. When I run software-center I cannot install or remove software. I get the following warning:

softwarecenter.backend - WARNING - _on_trans_error: org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name':  ':1.105'}): org.debian.apt.install-or-remove-packages

It worked just fine outside Awesome wm. I searched on google/askubuntu and found this post, which seemed to had the solution (gksudo software-center & exit).

Now I can install new software, but I can't view or search my installed software . The page just keeps showing the loading icon, but won't ever load. I don't get any warnings or errors.

Just to be clear, installing/removing/searching using synaptics/apt-get/dpkg works just fine.

share|improve this question

closed as off topic by qbi, hhlp, Mik, Eric Carvalho, Eliah Kagan Jan 22 '13 at 1:17

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
The question, you mentioned, lists this behaviour as a bug. Please see bugs.launchpad.net/ubuntu/+source/software-center/+bug/1045186 –  qbi Jan 21 '13 at 9:59
    
Since this is a bug, this question will probably be closed as off-topic, in accordance with the FAQ and this policy. Please note that you can run Software Center with sudo rather than PolicyKit as a workaround (as stated in comments in the bug report). The best way to do that is usually to press Alt+F2 and run gksu software-center. –  Eliah Kagan Jan 22 '13 at 1:17
add comment