Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have attached an image of the badly rendered font.

bad rendered fonts image

This started happening after upgrading 12.04 (I was on 10.10 before that). The chrome version is Version 22.0.1229.39 beta. Font for the text in multi-color is "CallunaBlack". If I change it to Arial or Times New Roman, it is displayed correctly. The problem may be limited to webfonts.

Initially I had problem with many fonts. Taking hint from some earlier answers, I created .fonts.conf as below. This helped in getting the regular fonts rendered correctly.

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>none</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintslight</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
   <edit mode="assign" name="lcdfilter">
    <const>lcdlegacy</const>
   </edit>
 </match>
</fontconfig>

I tried different options for the parameters here but no success.

Everything looks good on firefox

share|improve this question

1 Answer 1

up vote 3 down vote accepted

I faced the same problem. Following steps fixed the issue.

  1. Install gnome-tweak-tool: sudo apt-get install gnome-tweak-tool
  2. Open Advanced settings from dash.
  3. Select "Fonts".enter image description here
  4. Select "Grayscale" or "None" for the "Antialiasing" setting.

This issue is with the recent version of chrome. If you don't want to do the above steps I would recommend you to downgrade the chrome version.

share|improve this answer
    
It is all set now. Thank you –  Max Sep 12 '12 at 11:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.