Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to change the shortcut for switching applications from Alt+Tab to Ctrl+Tab, but changes in the System Settings > Keyboard > Shortcuts > Navigation are being ignored. Even if I disable the Switch applications shortcut entirely, it still maps to Alt+Tab. At one point I had some keys remapped with xmodmap, but since then I have deleted that configuration and rebooted. My keyboard layout settings are all defaults. The OS is Ubuntu 12.04, with all software updated this afternoon.

It would also be nice to have the variation of application switching that includes one icon per window, instead of one icon per application, since I am frequently switching between windows of an application and would rather not wait for the switcher to realize I want a different window of the current application. My other Ubuntu 12.04 install has the application switcher that I like, but I'm not sure how to choose between them on this install (which was set up by my university department). Thanks if anyone can help me with this.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I think you will have to install the Compiz Settings Manager (aka ccsm) and play with the settings of the Unity / other switcher plugins. Unfortunately, ccsm can be dangerous and can make Compiz crash or disable all the plugins, so do that if you know what you are doing or are ready to deal such bugs.

share|improve this answer
    
Compiz has an even better app switcher that lets me choose any key binding. No more stretching for tab :-) Thanks! –  Byron Hawkins Sep 12 '12 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.