Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here's me in gnome-terminal, using telnet.

enter image description here

As it says "Escape character is '^]'

I've no idea which keys to hit, CTRL ] , CTRL Å , CTRL ^ does nothing.

This is the keyboard layout of Norwegian keyboards - which keys do I hit to get to the telnet escape prompt ?

enter image description here

share|improve this question
    
Given your keyboard layout, <kbd>Ctrl</kbd><kbd>AltGr</kbd><kbd>9</kbd> should work, doesn't it? –  January Sep 12 '12 at 2:41
    
That's CTRL ] , so yes it should. It doesn't. CTRL AltGr 9 Enter does work in Fedora and RHEL though –  nos Sep 12 '12 at 7:08
add comment

2 Answers 2

You can set up the escape character you want by passing the option -e " your escapechar"

-e escapechar -Sets the escape character to escapechar. If no character is supplied, no escape character will be used. Entering the escape character while connected causes telnet to drop to command mode.

share|improve this answer
1  
As mentioned CTRL Å doesn't work (upper case nor lower case) –  nos Sep 12 '12 at 0:11
    
What LnxSlck just wrote means that you can start telnet with an option specifying just any kind of escape character. –  January Sep 12 '12 at 2:43
add comment

Gnome Terminal does not pass the escape sequence to the telnet session. The only way is setting a different escape char when starting telnet, or using a different terminal emulation other than the gnome terminal.

share|improve this answer
    
This is not good answer. Provide proof links please. Also explain how to set different escape character. –  c0rp Apr 7 at 10:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.