Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So disclaimer, I am using Lubuntu 12.04 but I'm almost certain it shouldn't make any difference.

Earlier this week I resized my lubuntu partition on my harddrive with GParted to be 25 GBs smaller, the rest being unallocated space. This is when my problem begin. I have then since resized the Lubuntu partition back to being the full size of my harddrive (minus swap, etc.) but the problem still persists.

I noticed after the resizing that when using google chrome and trying to download files I was getting download errors. After such errors would occur my / directory would be mounted as "read-only". For example trying to create a directory would prompt Error creating directory: Read-only file system It seems to only occur either by downloading something from chrome and then trying to put it in the trash or downloading something from chrome and then closing chrome. As any combination of downloading things, deleting them, or closing a program doesn't cause this error if I'm say using Firefox or Epiphany.

I have tried repairing the file system with fsck -yfv /dev/sda1 while using a live cd but unless the "read only" error had occurred the previous boot it doesn't find any errors. Same with when I boot the system, if the "read only" error had occured previous boot, lubuntu finds and tries to fix the file system error on boot. After which the file system works and is read/write again.

I have also tried reinstalling chrome with

sudo apt-get purge google-chrome-stable

and then

sudo apt-get install google-chrome-stable

to no avail.

I apologize if this is too verbose, but any help would be greatly appreciated.

EDIT: Here is the dmesg output when the error occurs

[  803.965630] EXT4-fs error (device sda1): ext4_ext_search_left:1224: inode #655737: comm flush-8:0: ix (3646) != EXT_FIRST_INDEX (0) (depth 0)!
[  803.965643] Aborting journal on device sda1-8.
[  804.017792] EXT4-fs error (device sda1): ext4_journal_start_sb:327: Detected aborted journal
[  804.017796] EXT4-fs (sda1): Remounting filesystem read-only
[  804.017975] EXT4-fs (sda1): Remounting filesystem read-only
[  804.017986] EXT4-fs error (device sda1) in ext4_da_writepages:2317: IO failure
[  804.019268] EXT4-fs (sda1): ext4_da_writepages: jbd2_start: 1023 pages, ino 655737; err -30
[  900.184077] CE: hpet increased min_delta_ns to 20113 nsec
share|improve this question
A reason for remounting your / filesystem should be mentioned in your kernel messages. Post relevant lines from the output of dmesg when it occurs. That should help finding the cause. – gertvdijk Sep 11 '12 at 22:41
That's unlikely to be caused by chrome - did you check for similar questions in the "Related" column on the right? -> – ImaginaryRobots Sep 11 '12 at 22:58
Yea I looked through pretty much every related post I could find here and on the rest of the internet. All I got was either to reinstall the OS, use fsck (which doesn't work for me) or that my drive is failing. I question the latter because this only started occurring after using GParted. The only directly related post is this… which has no answers. – C. Zach Martin Sep 11 '12 at 23:08
This looks like a problem introduced by the fs resizes that fsck isn't detecting. Probably not an easy fix. The only thing I could recommend is copying off your valuable data to another medium then reinstall the OS on a new filesystem. – allquixotic Sep 12 '12 at 0:42
that's what I was afraid of. Oh well at least I can still retrieve all my data. Thanks everyone! – C. Zach Martin Sep 12 '12 at 3:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.