Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I added this

X-Ayatana-Desktop-Shortcuts=User1;User2
[User1 Shortcut Group]
Name=Draconis
Exec=chromium-browser --enable-udd-profiles --user-data-dir="/home/xiaolin/.config/chromium/Default"
TargetEnvironment=Unity

[User2 Shortcut Group]
Name=Snoozie
Exec=chromium-browser --enable-udd-profiles --user-data-dir="/home/xiaolin/.config/chromium/Profile 1"
TargetEnvironment=Unity

to:

~/.local/share/applications/chromium-browser.desktop

then logged out and back in, even tried rebooting, also tried adding it with:

gksu gedit /usr/share/applications/chromium-browser.desktop.

Nothing seems to work, all I get is the default quicklist.

share|improve this question
add comment

1 Answer 1

I think that the problem could be that you have 2 fields named "X-Ayatana-Desktop-Shortcuts"
You can try the following:

  • edit the .desktop file gksu gedit /usr/share/applications/chromium-browser.desktop.

  • search for the field "X-Ayatana-Desktop-Shortcuts" below the label "[Desktop Entry]" and add the "User1 and User2", should look like this:

enter image description here

Finally add your code for the two shortcut at the end of the file. (without the X-Ayatana-Desktop-Shortcuts=User1;User2)

[User1 Shortcut Group]
Name=Draconis
Exec=Exec=chromium-browser --enable-udd-profiles --user-data-dir="/home/xiaolin/.config/chromium/Default"
TargetEnvironment=Unity

[User2 Shortcut Group]
Name=Snoozie
Exec=chromium-browser --enable-udd-profiles --user-data-dir="/home/xiaolin/.config/chromium/Profile 1"
TargetEnvironment=Unity

Hope it will be useful to you!

Regards.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.