Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran sudo apt-get install -y unity-dictionary-lens and received a warning of unmet dependencies:

unity-dictionary-lens : Depends: unity-singlet (>= 0.2.0) but it is not installable

I found the package here but could not install it.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

It should reference python-unity-singlet. I can fix that pretty easily, but it has some other problems, right now it doesn't work at all even if you can install it. In the future you should just file a bug about stuff like this. Here's the relevant bug for this one:

https://bugs.launchpad.net/onehundredscopes/+bug/1030284

share|improve this answer

Most probably, you haven't enabled the universe repository of Ubuntu, as unity-singlet is located there and not available in the main repository.

Check your settings in 'Software Sources' or modify you /etc/apt/sources.list accordingly in order to enable 'universe'.

share|improve this answer
    
Thanks for the suggestion. I checked /etc/apt/sources.list and saw that numerous lines ending with universe were uncommented. –  Emre Sep 11 '12 at 21:19
    
If universe is enabled, then there might be other reasons for why apt has chosen to mark the package as not installable. For example, when your system has conflicting packages installed that prevents installing unity-singlet. What is the output when installing the package manually from the repositories, i.e. sudo apt-get install unity-singlet (after purging your current one first)? –  gertvdijk Sep 11 '12 at 21:28
    
I get Package 'unity-singlet' has no installation candidate. I just checked Software Sources and see check marks on main, universe, restricted, and multiverse. –  Emre Sep 11 '12 at 21:50
1  
I overlooked some very important difference in my answer. I've located the binary package python-unity-singlet instead of unity-singlet. It seems your package unity-dictionary-lens is just broken and has a dependency on the source package name. Try to report this error to the package maintainer. –  gertvdijk Sep 11 '12 at 21:53

As pointed out by gertvdijk in his answer, the control information in unity-dictionary-lens should have pointed to the dependency python-unity-siglet.

Doing this worked for me:

apt-get download unity-dictionary-lens  
mkdir unity-lens  
dpkg -e unity-dictionary-lens_0.2_all.deb unity-lens  
dpkg --extract unity-dictionary-lens_0.2_all.deb unity-lens  
dpkg-deb --build unity-lens  

sudo gdebi unity-lens.deb  
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.