Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am working with Ubuntu Quickly, and I ran the quickly design command, then deleted the menubar. But when I run, i get this error:

AttributeError: UiFactory instance has no attribute 'helpMenu'

I tried commenting out sections, but a simple search of the source code doesn't show helpMenu.

And google search for "Quickly" gives you a LOT of false positives ...

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The problem comes from the modified base Window class that quickly has in _lib/Window.py:

Traceback (most recent call last):
  File "bin/testapp", line 33, in <module>
    testapp.main()
  File "/home/ian/pythontesting/testapp/testapp/__init__.py", line 33, in main
    window = TestappWindow.TestappWindow()
  File "/home/ian/pythontesting/testapp/testapp_lib/Window.py", line 35, in __new__
    new_object.finish_initializing(builder)
  File "/home/ian/pythontesting/testapp/testapp/TestappWindow.py", line 24, in finish_initializing
    super(TestappWindow, self).finish_initializing(builder)
  File "/home/ian/pythontesting/testapp/testapp_lib/Window.py", line 61, in finish_initializing
    LaunchpadIntegration.add_items(self.ui.helpMenu, 1, True, True)
AttributeError: UiFactory instance has no attribute 'helpMenu'

The builder no longer has a menu. It's in a try/except block so should fail nicely but doesn't because it won't handle attribute errors. Modify the Window.py file so that line 63 reads:

except (ImportError, AttributeError):

Now it should work and does for me. I submitted a bug report to launchpad: https://bugs.launchpad.net/quickly/+bug/1051686

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.