Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have some issues regarding SSH and i am unable to solve . I have completed bootstrap and node status is 1 node allocated to maas, Now when i do juju status, it says invalid ssh key , hostname cannot be found error. .. I then went to /etc/hosts file and i changed

127.0.0.1     localhost  

to my

127.0.01     Node1

Now it gives me , error SSH forwading error: @@@@@@@@@@@@@@@@@@@@@@@@@@

I also have run the node after bootstrap and it gives ssh key .. I didnt added any ssh key in my Dashboard of MAAS.

Secondly i want to ask how can i make more nodes allocated to root?

Do i have to rewrite the maas-oauth portion in environment with another API key . Kindly Reply ASAP ....

share|improve this question

3 Answers 3

You should leave the "localhost" text on the 127.0.0.1 line - various things depend on that existing. Instead, you probably wanted to add your hostname to that line:

127.0.0.1     localhost node1

Your question also says "127.0.01" without the third "." - hopefully that's a typo in the question and not in your /etc/hosts file.

NOTE: hostnames should always be lowercase, case is ignored but that doesn't mean it won't cause problems.

share|improve this answer

Before juju will connect to the nodes, you must reboot them AFTER doing the juju bootstrap. This will cause them to install new software, including the keys necessary to enable communications.

share|improve this answer

The reason for that is key has been alternate from the one exists in the .ssh/known_hosts file.

If you are certain the system has not been compromised, you can simply remove the host key in the known_hosts file and accept the new one again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.