Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I happen to be using xubuntu but I dont think the desktop-environment is applicable in this context.

I noticed that some gnome-based applications such as rhythmbox cannot fetch any information from the internet if the corporate network is using a proxy.

In this particular scenario - the cover-art search facility of rhythmbox cannot find coverart sought from the various providers on the internet.

I've tried the usual tricks such as setting *http_proxy* and running rhythmbox from the terminal, but this does not seem to work.

Any ideas?

share|improve this question

1 Answer 1

up vote 6 down vote accepted

Some of the newer GTK3 based gnome-applications ignore/don't use environment variables when dealing with proxies.

Instead, they use values stored in gsettings / dconf

If you use dconf-editor installed as part of the dconf-tools package you can define the proxy in a GUI manner.

First - set the proxy mode to manual as shown

enter image description here

Second - set the proxy host & port. If you dont have an anonymous proxy you need to set the authentication-password and authentication-user values

enter image description here

If your corporate network uses https then set the equivalent system - proxy - https tree values instead of system - proxy - http that is shown above.

Via the terminal you can use the following:

gsettings set org.gnome.system.proxy mode 'manual' 
gsettings set org.gnome.system.proxy.http host 'proxy.askubuntu.com'
gsettings set org.gnome.system.proxy.http port 8080
gsettings set org.gnome.system.proxy.http authentication-user '[host]\[username]'
gsettings set org.gnome.system.proxy.http authentication-password 'mypassword'

Where [host]\[username] corresponds to your corporate network credentials e.g. mywindowsdomain\fossfreedom

If your corporate network uses https then substitute http with https in the above terminal commands.

share|improve this answer
    
Fantastic, thanks, I'll add this to the general non-Unity proxy settings answer! –  izx Sep 11 '12 at 14:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.