Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Firestarter to implement a firewall for my server - an Ubuntu 10.04 installation. Now, when ever a wireless connection attempts to connect and get an IP address via DHCP, it fails with a request timeout. From the log it appears to be communicating with the wireless hub and on the server I'm getting the following:

Unknown InputIN=eth1 OUT= MAC=ff:ff:ff:ff:ff:ff:xx:xx:xx:xx:xx:xx:xx:xx SRC=0.0.0.0 DST=255.255.255.255 LEN=328 TOS=0x10 PREC=0x00 TTL=128 ID=0 PROTO=UDP SPT=68 DPT=67 LEN=308

This did used to work. Anyone any idea what's up and how to fix it?

As an additional point, the DHCP works fine with wired connections and doesn't log the above message.

EDIT: Samba domains/share have stopped working on the wired LAN - they did work at one point, but they don't anymore. I might have to experiment with the various rules to see what happens.

share|improve this question

closed as too localized by Marco Ceppi Feb 3 '12 at 0:55

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question seems abandoned, there is not further information or activity added to it for several months. I am flagging this to be closed by a moderator. If you think this issue is still affecting you you can flag a moderator to re-open it. –  Bruno Pereira Feb 3 '12 at 0:35
add comment

2 Answers 2

Try rerunning the Firestarter wizard and select the wireless network connection instead of the wired connection.

share|improve this answer
add comment

Couple of things to check -

It definitely looks like your server is denying port 68 from broadcast, so I'm not clear how this is working via ethernet and only failing via wireless. Very strange.

Have you disabled the built-in DHCP server on your router (assuming it's a bog-standard ADSL/WAN router)? Is it possible that it's answering the DHCP request for WIFI connections before your Ubuntu server can respond?

Finally, Firestarter is getting a bit long in the tooth (I think), and has been "officially" replaced by uncomplicated firewall (ufw). If you want a GUI, try out gufw :

sudo apt-get install gufw

...and try adding a UDP port 67 inbound allow rule on that. The source port should be port 68 if you want to tie it down, but probably no need.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.