Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Linux, never used it before. I can follow instructions but don't know much about it. Tried searching for a solution to this but couldn't find one. I installed Ubuntu 12.04. It was working fine. Now when I boot up, I get BIOS splash screen, brief purple screen, then a completely black screen that says:

"Ubuntu 12.04.1 LTS [Ubuntu name] tty1

[ubuntu name] login:"

I can enter in my username and password, then it says:

"last login: Mon Sep 10 18:37:03 EDT 2012 on tty1
Welcome to Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-30-generic x86_64)

*Documentation: https://help.ubuntu.com/

0 packages can be updated
0 updates are security updates"

I had this issue, did a fresh install, and then continued having this same problem. At some point I was also just getting a black screen with a cursor. I think sometimes all it said was [ok].

Please help - thanks!

share|improve this question
    
if I press Ctrl+Alt+F7 it goes to a black screen that says [OK] in the top middle and blinking cursor one line below. once I login it says what I wrote above: last login: Mon Sep 10 18:37:03 EDT 2012 on tty1 Welcome to Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-30-generic x86_64) *Documentation: help.ubuntu.com 0 packages can be updated 0 updates are security updates" –  Adam Sep 10 '12 at 23:16
    
I have integrated graphics - intel 2500k –  Adam Sep 10 '12 at 23:17
    
re: graphics issue -- sometimes after BIOS flash it says something about poor graphics. Related? If so, thoughts on fixing? –  Adam Sep 10 '12 at 23:18
    
You can also get debugging info from startx into a file by using sudo startx|tee ~/startxdbg.txt` and examining it at your leisure with nano ~/startxdbg.txt If you can mount a flashdrive, you can also copy this file to that flash drive and use another computer to inspect it. Make sure you use Wornpad, not Notepad if you re going to use it on Windows. –  hexafraction Oct 5 '12 at 10:35
add comment

1 Answer 1

What it means is that for some reason the graphics doesn't work, but otherwise the system is fine. Laugh not: what you see is the regular login screen on a Ubuntu server edition, or a typical Unix login screen for many, many years.

This can be for example due to a problem with a graphics driver. There are a few things you can do to correct the problems. After you log in, try the following:

  1. Type startx at the command prompt. This will, most likely, fail, but it will also print out a reason for the failure.

  2. Copy the file /var/log/Xorg.0.log to an USB stick or a Windows partition (your USB stick should work as usual), using command like cp /var/log/Xorg.0.log /media/XXX, where XXX is the name of your USB stick. Upload it to http://paste.ubuntu.com.

  3. At the minimum, tell us what graphic adapter you have (my guess is: Nvidia)

share|improve this answer
    
Thanks. So, after pressing ctrl+alt+f7, as suggested above, I rebooted. Then -- ta da -- Ubuntu booted normally. While that's great, I know that I will have this issue again. Having said that, i can't now try your suggestion. I don't have a video card. Just the integrated intel graphics. –  Adam Sep 10 '12 at 23:22
    
I did just find that file and pasted it as you suggested. It's here: paste.ubuntu.com/1197686/ –  Adam Sep 10 '12 at 23:26
    
Hm. So there was some problem with your graphic adapter (yes, the on-board graphics adapter counts as such). Next time that happens, make sure to copy the Xorg.0.log file. Actually, you could bother to find the one from the crash -- look into /var/log, there will be a file called Xorg.0.log.old, maybe that is the file from the crash. Compare it with the current log Xorg.0.log; that should give us a hint about what the problem was. –  January Sep 10 '12 at 23:27
    
About the file you pasted: I'm afraid that is the log from when X started correctly. Please post the Xorg.0.log.old file. Every time the graphics starts, a new Xorg.0.log file is started; the old one is moved to Xorg.0.log.old, and the previous Xorg.0.log.old is deleted. –  January Sep 10 '12 at 23:28
    
there is the Xorg.0.log.old file, but I can't open it. Plus it may not matter because I successfully rebooted in between –  Adam Sep 10 '12 at 23:29
show 14 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.