Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How to remove permanently those error prompts while using openbox gnome? Such as: update ubuntu latest release, this kind of errors etc, how to permanently disable them so that it does not show in front of my presentation.

enter image description here

Follow up:

a) How do i kill that screen shot error box?

$ cat /etc/default/whoopsie

[General]
report_crashes=false

$ apport-cli

*** Send problem report to the developers?

After the problem report has been sent, please fill out the form in the
automatically opened web browser.

What would you like to do? Your options are:
  S: Send report (69.7 KB)
  V: View report
  K: Keep report file for sending later or copying to somewhere else
  I: Cancel and ignore future crashes of this program version
  C: Cancel
Please choose (S/V/K/I/C): I

b) How do i kill that update notification dialog box?

$/etc/xdg/autostart# vim update-notifier.desktop 
#NoDisplay=true
NoDisplay=false
:wq

$ cat update-notifier.desktop | grep NoDisplay
NoDisplay=false

No more disturbing popup's now.

Final follow up:

root@sun-Inspiron-One-2320:~# apt-get -f remove apport update-manager update-manager-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 apport-gtk : Depends: apport (>= 0.41) but it is not going to be installed
 opera:i386 : Depends: libc6:i386 (>= 2.3.2) but it is not going to be installed
              Depends: libc6:i386 (>= 2.3.6-6~) but it is not going to be installed
              Depends: libfontconfig1:i386 but it is not going to be installed
              Depends: libfreetype6:i386 (>= 2.2.1) but it is not going to be installed
              Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
              Depends: libglib2.0-0:i386 (>= 2.16.0) but it is not going to be installed
              Depends: libgstreamer-plugins-base0.10-0:i386 (>= 0.10.16) but it is not going to be installed
              Depends: libgstreamer0.10-0:i386 (>= 0.10.15) but it is not going to be installed
              Depends: libice6:i386 but it is not going to be installed
              Depends: libsm6:i386 but it is not going to be installed
              Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed
              Depends: libx11-6:i386 but it is not going to be installed
              Depends: libxext6:i386 but it is not going to be installed
              Depends: libxml2:i386 (>= 2.6.27) but it is not going to be installed
              Depends: libxrender1:i386 but it is not going to be installed
              Depends: libxt6:i386 but it is not going to be installed
              Depends: zlib1g:i386 (>= 1:1.1.4) but it is not going to be installed
              Depends: gstreamer0.10-plugins-good:i386 but it is not going to be installed
              Depends: fonts-liberation:i386 but it is not installable or
                       ttf-liberation:i386 but it is not installable or
                       ttf-mscorefonts-installer:i386 but it is not installable
              Recommends: flashplugin-nonfree:i386
              Recommends: cups-client:i386 but it is not going to be installed
 update-notifier : Depends: update-manager-gnome but it is not installable or
                            update-manager but it is not going to be installed
 xdiagnose : Depends: apport but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

For the first dialog, try uninstalling apport. For the second, you can remove update-managerand update-manager-core, assuming that @mikewhatever's got the correct package names (I'm not on an Ubuntu machine at present).

You can do it this way:

sudo apt-get remove apport update-manager update-manager-core

I'm fairly confident about apport, because that's the program that handles automatic bug reports. Instead of mucking about with the configuration, just get rid of it since you don't like it.

share|improve this answer
    
Thank you. It works now perfectly. Was confusing which packages was poping out. –  YumYumYum Sep 18 '12 at 5:15
add comment

The error above is probably related to whoopsie, the crash report daemon. You could disable it by editing /etc/default/whoopsie, and changing report_crashes=true to false. As for for updates, the best solution, IMHO, would be to install them, however, if that's not possible, disable the update checker and the update notifier.

What other errors do you get?

share|improve this answer
    
i did you way. But still same after 10 time reboot having "report_crashes=false" –  YumYumYum Sep 10 '12 at 23:19
    
See my follow up, option 2 works to kill the screenshot. But i have another issue the updates prompt always daily it shows up. How do i kill that one? –  YumYumYum Sep 10 '12 at 23:31
1  
Hm..., not sure. What you did about the update-notifier would only unhide it from autostart programs. To disable it, that entry must be removed from /etc/xdg, but since you probably don't need an update manager, uninstall update-manager and update-manager-core, or whatever you have installed there. I don't think those are OpenBox packages. –  mikewhatever Sep 11 '12 at 0:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.