Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have bought a laptop with Ubuntu 12.04, which runs fine but wants to update. I don't have the password and it won't let me update anything. I have downloaded 12.04 in order to re-install it and it tells me it isn't suitable for my processor.

The machine is a Dell latitude D505. I tried downloading the i386 version and on booting with the disc, I get:

This kernel requires features not present on CPU. pae. Unable to boot. 

All I'm trying to do is to let software updater do it's stuff but as it asks for a password, I can't proceed. I've tried changing password in root shell but that doesn't work.

Any ideas?

Nothing seems to be working with this problem, so maybe I'll just wait for the next official release and try again.

share|improve this question
2  
What is the MAKE and MODEL of your laptop? Have you downloaded the 32bit or 64bit version? You might look at the right of this screen at "Related: How do I reset a lost Administrative (root) password?" –  arochester Sep 10 '12 at 20:23
    
What program is asking for a password? Ubuntu doesn't have a root password by default; for most actions requiring root privileges, it will ask for the password for your personal account. Are you missing the password for your own account? If you install 12.04 from scratch, wiping out your current installation, you'll be able to set a new password. –  Keith Thompson Sep 10 '12 at 20:35
add comment

2 Answers 2

Ubuntu doesn't have a root password by default. Actions that require root privileges are generally done via sudo which requires the password for your own account.

If you don't have the password for your user account, you can set one by rebooting in single user mode, which will give you a root shell. You can then type

passwd yourname

where yourname is your user account name. Then reboot in normal mode and you should be able to use the password you just set.

Instructions for booting in single user mode can be found here. (This isn't as big a security hole as it seems, since it requires physical access to the system; the bad guys can't get a single user shell remotely.)

And as ObsessiveFOSS's answer says, you need an iso image that's appropriate for your CPU architecture, most commonly either "i386" or "amd64". Once you have an installation disk that's compatible with your architecture, you can install from scratch (wiping out everything you now have on the system), and you'll be able to set a password. If you do this, you won't need to boot into single user mode. Downloads for the current version are available from releases.ubuntu.com:

Thanks to ObsessiveFOSS for providing these links.

(Note that "AMD64" refers to an architecture originally developed by AMD, but available from AMD, Intel, and elsewhere.)

Don't bother setting a root password; it's not needed, and having one can open a potential security hole.

share|improve this answer
    
Can you add the links I gave t your answer? Then, I'll delete mine as it is not needed. –  hexafraction Sep 11 '12 at 20:31
    
@ObsessiveFOSS: Done, thanks –  Keith Thompson Sep 11 '12 at 21:56
add comment

To re-download Ubuntu: use this if it gives an error about there not being an AMD64 processor: http://releases.ubuntu.com/12.04.1/ubuntu-12.04.1-desktop-i386.iso

If it gives an error about PAE and you have a 64-bit processor(or the other file doesn't work), use http://releases.ubuntu.com/12.04.1/ubuntu-12.04.1-desktop-amd64.iso

All files are from the official releases server at releases.ubuntu.com.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.