Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, the computer suspends just fine. When I try to wake it up, the screen flickers a bit, and then there's a black screen with all kinds of awful colored lines all over it. The mouse works normally, but it seems to be the only thing that functions. The only way to fix it seems to be doing a hard power off.

My graphics card is Nvidia, but that's all I really know about it.

My computer is a HP Pavillion dv9000.

share|improve this question
2  
Did you try to install the nVidia drivers by opening a program called Additional Drivers and activating a driver? It's OK if you're unsure, but it is something that is only done by manual user request and can cause changes that can cause the issue you are having. –  hexafraction Sep 10 '12 at 19:31
    
@ObsessiveSSOℲ, thanks for your comment! That fixed my problems with suspending :) –  Geerten May 9 '13 at 10:07
    
@hexafraction Please, move your comment into an answer. –  Lucio Nov 2 '13 at 2:15
    
@Lucio Done. –  hexafraction Nov 2 '13 at 12:02
add comment

2 Answers

You should install the nVidia drivers. A program or section of software center (depending on Ubuntu version) is available for your use. Within that utility, select and activate the nvidia driver(current is optimal but past versions can be selected if the current is broken for your setup). Authenticate if prompted to, and reboot when finished.

Did you try to install the nVidia drivers by opening a program called Additional Drivers and activating a driver? It's OK if you're unsure, but it is something that is only done by manual user request and can cause changes that can cause the issue you are having.

share|improve this answer
add comment

Try experimenting the arguments of pm-suspend, for example, to get the command line options, run as root

# pm-suspend --help

Then try, for example,

# pm-suspend --quirk-radeon-off

If some quirk works for you, then all you have to do is to edit /usr/sbin/pm-suspend and set the variable PM_CMDLINE to PM_CMDLINE="--quirk-radeon-off $@" or whatever option works for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.