Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed cluster-SSH on my ubuntu 10.04 server, it has a dependency of xterm_261-1_amd64. when i try to $cssh localhost it says

ocpe@blrkec241933d:~$ cssh localhost
connect /tmp/.X11-unix/X0: No such file or directory

and when i try to open xterm it says.

ocpe@blrkec241933d:~$ xtermconnect /tmp/.X11-unix/X0: No such file or directory

xterm Xt error: Can't open display: localhost:10.0

Is it coz ubuntu server does not have any UI???? . I just log into it through putty from my windows machine and work. i dont have any idea, if at all i can fix it.. plz help.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

You are right: the problem is your Ubuntu Server doesn't have a GUI (or specifically, an X server)

Cluster-SSH is designed to use multiple xterms, which is only possible if an X server is running locally; if you are running cluster-SSH over SSH itself, then you'd need X forwarding enabled.

Setting up an X server in Windows isn't easy, and in any case, cluster-SSH with its multiple terminals wouldn't be very responsive if forwarded over the Internet.

share|improve this answer
    
is'nt there any other way or any other tool, so that i can run commands parallely on multiple ubuntu systems, with very less time skew!! –  user1587153 Sep 11 '12 at 4:41
    
You mean a tool that will run from Windows? –  izx Sep 11 '12 at 4:43
    
i just want a tool, whether its on windows or on my ubuntu system. It should just be able to run commands in parallel on multiple systems. Only one system with ubuntu GUI is enough to use cluster-ssh, or will it work only when all the system in cluster has a GUI!!? –  user1587153 Sep 11 '12 at 5:22
add comment

you must set X11Forwarding to yes in /etc/ssh/sshd_config file on the machine to which you are ssh'ing.

Restart sshd after setting the above.

Hope this helps

share|improve this answer
    
Thnx, for ur help. X11Forwarding is already set to yes, and its giving the same error. –  user1587153 Sep 11 '12 at 4:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.