Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have VAIO VPCEA23EN with Ubuntu 12.04 32 Bit.

Bluetooth is working but not WiFi.
It says "disabled by hardware switch" even when it's enabled.

share|improve this question
You tried toggling the wifi switch? Also did you check to see if wifi is enabled in bios? Also, did you check System Settings > Additional Drivers? – hnasarat Sep 10 '12 at 15:22
if you want help, you need to tell us what kind of wireless card you have, not what kind of computer you have. – RobotHumans Sep 10 '12 at 16:05
up vote 2 down vote accepted

Open the terminal. the shortcut is:

Ctrl + Alt + T

Then type this command:

sudo rfkill unblock all

If it did not work from the beginning.Try typing it again like 2 or 3 times and then see

Sometimes the hard switch won't work. So this command works like a hard switch and helps enabling the Wifi.

share|improve this answer
that won't help if it's reading as disabled by hardware switch – RobotHumans Sep 10 '12 at 16:05
Thanks for Down-voting my solution. I guess if you have a better solution you can Lighten us with it :) – Suhaib Sep 10 '12 at 16:38
@Suhaib - I've up-voted it... – horIzoN Apr 17 '13 at 16:48
@nerof61 thanks, you are awesome – Suhaib Apr 17 '13 at 17:57
@Suhaib - No problem... – horIzoN Apr 17 '13 at 19:05

I have seen similar behaviour with my Dell E5430. If the machine is booted with the hardware switch in the off position, then toggling it does nothing, and the wireless interface cannot be activated until the machine is rebooted with the switch in the 'on' position.

Once this is done - the hard switch works as expected - powering the wireless card up and down.

share|improve this answer

I have a similar problem with my asus x550c notebook none of the above answers helped but I have found that if I boot up and log in then close the lid and then open the lid again when I log in again the wi fi will be working hope this helps other users

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.