Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a “dumb” printer attached to a parallel port in my machine which works fine under the “other” resident operating system (from Redmond) on the same machine. I recently added Ubuntu 12.04 as a dual boot on the machine, but Ubuntu doesn't seem to recognize the parallel port at all. All I need to set up a printer is a really plain-vanilla fixed pitch text-only generic driver, which is present, but no parallel ports show up. (The other printers, all on USB ports, seem to work just fine).

Following what appeared to me to be the most reasonable of the many conflicting pieces of advice on the web, here's what I did:

I added the following lines to /etc/modules

  • parport_pc
  • ppdev
  • parport

Then, after rebooting, I checked to see that the lines were still present, and they were.

I ran

dmesg | grep par

and got the following references in the output that seemed like they might have to do with the parallel port:

[   14.169511] parport_pc 0000:03:07.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[   14.169516] PCI parallel port detected: 9710:9805, I/O at 0xce00(0xcd00), IRQ 21
[   14.169577] parport0: PC-style at 0xce00 (0xcd00), irq 21, using FIFO [PCSPP,TRISTATE,COMPAT,ECP]
[   14.354254] lp0: using parport0 (interrupt-driven).
[   14.571358] ppdev: user-space parallel port driver
[   16.588304] type=1400 audit(1347226670.386:5): apparmor="STATUS" operation="profile_load" name="/usr/lib/cups/backend/cups-pdf" pid=964 comm="apparmor_parser"
[   16.588756] type=1400 audit(1347226670.386:6): apparmor="STATUS" operation="profile_load" name="/usr/sbin/cupsd" pid=964 comm="apparmor_parser"
[   16.673679] type=1400 audit(1347226670.470:7): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper" pid=1010 comm="apparmor_parser"
[   16.675252] type=1400 audit(1347226670.470:8): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/mission-control-5" pid=1014 comm="apparmor_parser"
[   16.675716] type=1400 audit(1347226670.470:9): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/telepathy-*" pid=1014 comm="apparmor_parser"
[   16.676636] type=1400 audit(1347226670.474:10): apparmor="STATUS" operation="profile_replace" name="/usr/lib/cups/backend/cups-pdf" pid=1015 comm="apparmor_parser"
[   16.677124] type=1400 audit(1347226670.474:11): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/cupsd" pid=1015 comm="apparmor_parser"
[ 1545.725328] parport0: ppdev0 forgot to release port

I have no idea what any of that means, but the line “parport0: ppdev0 forgot to release port ” seems unusual.

I was still unable to add a printer for my old clunker, so I tried the direct approach, typing

echo “Hello” > /dev/lp0

and received a Permission denied message. I then tried

echo “Hello” > /dev/parport0

which didn't give me any message at all, but still didn't print anything.

Running the command sudo /usr/lib/cups/backend/parallel gives the following:

direct parallel:/dev/lp0 "unknown" "LPT #1" "" ""

Checking the permissions for /dev/parport0, Owner, Group, and Other are all set to read and write.

crw-rw---- 1 root lp  6, 0 Sep  9 16:37 /dev/lp0
crw-rw-rw- 1 root lp 99, 0 Sep  9 16:37 /dev/parport0

The output of the command lpinfo -v includes the following line: direct parallel:/dev/lp0

I've read several web postings that seem to suggest this has been a problem for several years, but the bug reports were closed because there wasn't enough information to address the issue (shades of Microsoft!).

Any suggestions as to what I might be missing here?

share|improve this question

I am not absolutely sure but cuz your persmissions for lpt are set to root it came to my mind that it could have the following reasons:

a) Add your user to the lp user group. Use the following command to accomplish the task:

gpasswd -a [user] lp

Read the ArchWiki article on Users and Groups for more information on how Groups are used for access to certain system hardware.

Turns out there are multiple bugs on Launchpad regarding this issue. These may help:

From: (Read in another post)

Permissions needed to add printer

b) you could change the parport permissions to every user. But I am not sure if that would be a better idea.

sudo chmod 666 /dev/parport0

From: Fedora Parport permission - but the same in Ubuntu

share|improve this answer

This behavior is caused by FIFO option enabled. If you recompile your kernel with FIFO disabled, your printer will print like it did before.

There's a bug filled regarding this:

However the bad thing is I don't know when will they fix it :-(

share|improve this answer

Easy way. Permissions are disabled by default for root, follow this Q/A: ( and hope it will help.

share|improve this answer

Remove libsane-hpaio. This package grabs and holds the parallel port. The package is for HP scanners connected to LPT1.

What a headache!! I can't believe this goes on for so long.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.