Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday I installed Ubuntu 12.04.1 64bit in my laptop with windows 7. The installation was dual. I did the required partition and kept a free space for linux. I gave the appropriate space for swap area and ext4. Ubuntu got installed well. Then finally after installation, I was asked to reboot my system.

While rebooting, as we expect, the system should ask me whether I want to start windows or linux. But it did'nt ask me any of it. The system directly takes me to windows without giving me any option for linux. I tried restarting again, but i was directly taken to windows. Can you help me know this ? Did i go wrong somewhere with my installation? How can i correct it and get to linux ?

Thanks in advance..

I thank you for your reply. I am not sure in which partition did I install my grub. Honestly this is really new to me. I am trying to follow the instructions mentioned in the link you provided. It is really a clear description on how to install ubuntu step by step. But however, I am stuck at using the "EasyBCD" tool. I have tried installing several times, but after installing, when I try to run it, it gives me an error saying,

"error Opening BCD Registry"

I have attached the image as well. Could you give me an alternative ? Or any way to resolve that?

share|improve this question
Did you use a live USB to do the installation? Sometimes GRUB (the app that gives the choice at boot gets installed in the USB rather than in the hard drive. To test, try booting again with the USB inserted. If you see the choice, then search for the question and answer here. – user68186 Sep 10 '12 at 14:17

It seems that GRUB was not installed on the MBR.

Follow these steps:

  • Boot using a LiveUSB.

  • Open a terminal. Run the following commands:

    sudo grub-install /dev/sda
    sudo update-grub
  • Reboot.
share|improve this answer

In which partition did you install grub? If you didn't installed it on the same partition as Windows 7, then the default partition to boot will remain the Windows 7.

An easy way to fix this is to use EasyBCD to add ubuntu to Windows 7 boot entry menu. This link should help you: dual boot ubuntu 12.04 and windows 7

share|improve this answer
GRUB should not be installed on the Windows 7 partition, rather the Master Boot Record (MBR) of the disk drive. In other words if Windows 7 is installed on /dev/sda1, GRUB should go on /dev/sda and not on /dev/sda1. – user68186 Sep 10 '12 at 20:22
Thanks for correcting me. – ThiagoPonte Sep 10 '12 at 23:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.