Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After solving this problem I managed to get myself into truble again out of nothing by trying to change the display of the dual boot option page in Boot Customizer.

I have changed the background, the fonts size (I have increased them) and font style (I have chosen UnDotum). But Boot Customizer gave me an error (I mean a message that the application was closed unexpectedly or smth). I have restarted BootCustomizer and the settings were there. When I rebooted, instead of the normal boot options list, just the background image that I had selected and nothing else.

I used Boot Repair to repair grub, it says it did it successfully, but I still get the background image when I try to boot.

Any ideas?

(Could it be the matter that I chose UnDotum font style? That was installed in Lubuntu - but how could it be accessible in displaying boot options?)

The contents of etc/default/grub are:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I have tried to modify etc/default/grub: GRUB_HIDDEN_TIMEOUT=0 to 10 GRUB_HIDDEN_TIMEOUT_QUIET=true to false and GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to ""

but it doesn't help

Also, using Shift doesn't make the list visible.

I am looking for something like a command that would reset grub options to default.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The detailed instructions for resetting GRUB is here. Read this carefully and proceed with caution.

The basic steps are as follows:

  1. chroot as before and copy resolv.conf (may be needed to connect to the internet).

    sudo mount /dev/sda1 /mnt && sudo mount --bind /dev /mnt/dev && sudo mount --bind /proc /mnt/proc && sudo mount --bind /sys /mnt/sys && sudo mount --bind /dev/pts /mnt/dev/pts && sudo chroot /mnt

    sudo cp /etc/resolv.conf /mnt/etc/resolv.conf

  2. Confirm Internet connection. Without it GRUB cannot be reinstalled and you will have a unbootable system.

    sudo apt-get update

  3. Purge grub. This will remove GRUB and the config files.

    sudo apt-get purge grub grub-pc grub-common

  4. Install GRUB again.

    sudo apt-get install grub-common grub-pc

    1. Reinstall the grub packages.

Here is what will happen:

  • You will be given the opportunity to add extra kernel options to the kernel line. If you don't know, you probably don't need them ; TAB to highlight "OK" and press ENTER.
  • Read the installation notes. TAB to "OK" to continue.
  • When presented with the device option, use the UP/DN keys to select the correct drive (sdX).
  • Make sure the installation drive /dev/sdX has an asterisk (*) (or a red spot like in the image below) next to it. If it doesn't, highlight it by Up Arrow or Down Arrow and press the Space Bar to select it (= Just highlighting it with the up/down arrows is not enough to select it, you have to add that asterisk/dot - depending on the type of terminal - by pressing Space Bar.)

enter image description here

  • Do not select a partition ( example: [ ] /dev/sda5 , etc).

  • TAB to "OK" and press ENTER. When it has finishing the installation, you should have Grub 2 installed.

Hope this helps.

share|improve this answer
    
i uninstalled and during install i am asked whre to install grub. butthe only options are:GRUB install devices: [ ] /dev/sda (80026 MB; FUJITSU_MHT2080AH_PL) and [ ] /dev/sdb (2004 MB; USB_DISK) - as an usb is connected. if i select ok it says: :You chose not to install GRUB to any devices etc" (im in live cd) –  cipricus Sep 10 '12 at 15:00
1  
See expanded answer. You should choose /dev/sda. –  user68186 Sep 10 '12 at 15:08
    
is it ok that the only devices listed there were two: the cd rom and an usb drive? –  cipricus Sep 10 '12 at 15:21
    
Sorry, I didn't realize the only devices were the CD rom and the USB drive. Are you sure the /dev/sda is the CD ROM? It is 80GB in size. –  user68186 Sep 10 '12 at 15:24
1  
Select /dev/sda. Not /dev/sda5. GRUB should be installed in the MBR (Master Boot Record) of the disk drive and not inside any of the partitions of the disk. –  user68186 Sep 10 '12 at 15:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.