Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Ubuntu Netbook on my mum's Windows XP Atom notebook.

The notebook doesn't have an optical drive, nor do we currently have a usb drive in the house. So I decided to use Unetbootin to create the "frugal" hard disk loader.

The only thing is, now I'm stuck on the Allocate Drive Space screen during Ubuntu install.

The screen I'm stuck on looks like this:

screenshot

Sorry it's so blurry. Anyway, the two entries in the table start with "/dev/".

Regardless of which one I choose I get an error saying:

> No Root File System is Defined

Bear with me, because I don't know anything about partitions or stuff like that. I chose Ubuntu because it's user-friendly and because Windows is a pile of crap, particularly XP on a netbook.

Having said that, what's gone wrong, can you help?

Also, after choosing Unebootin from the boot options and it starts to load Ubuntu, it gives the option to press "esc" to load options. The screen that comes up looks like this:

screenshot

Now, out of those options, I've tried the first one, which says Unetbootin again, and the straight up "Install Ubuntu Netbook" options, but have come up against exactly the same issue both times.

Any ideas anyone?

share|improve this question

2 Answers 2

Looking at your top screenshot then what you need to do is select one of the partitions, then click on Change... below. On the dialogue that appears, you should select the ext4 file system, make the mount point / (the filesystem 'root') and also click the box to format this partition. Then close the dialogue. You should now be able to proceed with the install.

Please note this will remove Windows XP from the netbook (which would probably be very difficuly to restore) - so I would advise you check the LiveCD is working with the hardware (e.g. wireless) before going ahead with the install..

share|improve this answer
    
+1 thanks fluteflute, yep wifi's working ok. I'll try your suggestion now, and see how it goes, cheers –  andy Dec 23 '10 at 16:59
    
hmm... not sure about that. When I click "change" the the Edit Partition window is set to: "Use As: Do Not Use The Partition". I can change that, but which file system do I choose...?? –  andy Dec 23 '10 at 17:08
    
Select ext4. Sorry I had forgotten that step. –  8128 Dec 23 '10 at 17:12
    
thanks fluteflute. I actually tried with ext3 and then it asked me to select a swap partition, and I used the smaller partition, but then when it started installing it hung saying it couldn't umount /cdrom. Also, if I select my main partition (sda2) and the primary with format on, and sda1 and the swap, then what will happen to the unetbootin files..? This installation is not ruuning from an actual cdrom, so, won't I be deleting the files I'm running off...?? cheers –  andy Dec 23 '10 at 17:40
    
It makes little difference whether you use ext3 or etx4 :) Hmmm I'm a bit confused by the partitions presented to you - do you happen to know how big the hard drive is (perhaps by looking in Windows)? Also do you not get a screen like this one during the install? –  8128 Dec 23 '10 at 19:40

I have two partitions already defined: on one of them I had installed the previous OS and the second one contains data that I don't want to lose. How do I define a swap space?

Solved: I deleted one of the partitions and reallocated the freespace.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.