Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded my ubuntu 10.04 server to Ubuntu 12.04, after setting samba i'm facing few problems, samba recycle bin not working properly, i have set my existing partition as samba recycle repository but whenever i delete some thing samba just make folder tree but the deleted file is missing.

for example,

I delete :

/Audit-Data/SambaTest/test.doc

so in delete-files it shows :

/Audit-Data/SambaTest/

The file is missing.

if i set .recycle folder in my shared samba directory then samba recycle working fine.

share|improve this question

1 Answer 1

I just happened to have the same problem.

In my case I had set up my "recycle" folder on a different btrfs subvolume (read: different mount point I guess).

Turns out this solution worked:

Add crossrename to the vfs objects = recycle line.

Took it from there: https://bugzilla.samba.org/show_bug.cgi?id=8637#c5


Just a word of caution after some testing...

This workaround only worked for files under 20MB of size. For some reason, files over 20MB were not written to the recycle folder when the recycle:repository was set to a different subvolume than the shared folder.

To work around this please add the line

crossrename:sizelimit = 500

after the vfs_objects line, which makes it work for files up to 500MB

The problem was only completely solved when both the shared folder and the recycle folder were set on the same subvolume.

Hope this can help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.