Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Ubuntu on my ThinkPad T510, the GDM screen and GNOME session would always start at 100% brightness.

I quickly found out, that this can be controlled via gnome-power-preferences, but I'd like to have GDM and the GNOME session follow the global backlight setting (ie., when I set it during POST, GRUB, GDM, a GNOME session, or on a TTY, I expect it not to automatically change).

So, how can I make gnome-power-manager stop automatically changing my backlight level?

share|improve this question

1 Answer 1

up vote 10 down vote accepted

It seems this can only be disabled by editing a gconf setting using gconf-editor or the command line tool gconftool-2 (easier). As GDM is run by a special user (gdm), you got to disable it for the desktop user and that special user:

Run the following from a gnome-terminal:

gconftool-2 --set --type boolean  "/apps/gnome-power-manager/backlight/enable" false

This will deactivate the backlight control for your user. Now type:

sudo -u gdm gconftool-2 --set --type boolean  "/apps/gnome-power-manager/backlight/enable" false

This will deactivate the backlight control for the user that controls the GDM screen.

You should now no longer see automatic backlight level changes.


In Ubuntu 11.10 Oneiric Ocelot this changed to:

 gsettings set org.gnome.settings-daemon.plugins.power idle-dim-ac false
 gsettings set org.gnome.settings-daemon.plugins.power idle-dim-battery false

Still not sure how to disable it for the login screen.

share|improve this answer
1  
This command for ubuntu oneiric doesn't work.. can you correct it? –  fain182 Oct 15 '11 at 8:54
1  
I think is gsettings set org.gnome.settings-daemon.plugins.power idle-dim-battery false –  fain182 Oct 15 '11 at 10:13
    
@fain182 Thanks, updated. –  htorque Oct 17 '11 at 8:01
    
Is the section about GDM's user still accurate (given that we're not on LightDM)? Edit: I see the revised section below now. –  Oli Nov 2 '11 at 10:36
    
Not sure about GDM in 11.10. This should be tested with a fresh install, but I'm low on disk space on the device where I saw this happening. –  htorque Nov 2 '11 at 16:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.