Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Even though I have gapless playback enabled in Banshee's settings menu, there is a very short pause between songs. This might be due to the fact that my hard drive's partitions seem weird.

fdisk -l produces this output:

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x4a73c3cb

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      409599      203776    7  HPFS/NTFS/exFAT
/dev/sda2          409600   724153740   361872070+   7  HPFS/NTFS/exFAT
/dev/sda3      1456826368  1465145343     4159488    c  W95 FAT32 (LBA)
/dev/sda4       724154366  1456826367   366336001    5  Extended
Partition 4 does not start on physical sector boundary.
/dev/sda5      1440159744  1456826367     8333312   82  Linux swap / Solaris
/dev/sda6       724154368  1440159743   358002688   83  Linux

Partition table entries are not in disk order

Playing mp3's from /dev/sda2 or /dev/sda6 produces this problem. I don't seem to have gapless playback on Rhythmbox or Clementine either, if those media players are supposed to have it.

I'm not sure what other info to provide. This is just annoying to me. Thanks for any help.

Edit: this is in Ubuntu 12.04

share|improve this question

3 Answers 3

Based on my on research, I think the problem is that I am using MP3, which is compressed. A small gap is added at the beginning and end of each MP3 track, so it is apparently impossible to get true gapless playback. See the wikipedia page on gapless playback. I have the same problem while using Music on Console, which also supports "gapless playback".

Unfortunately, I don't have a solution, either.

share|improve this answer

The fact that Banshee does not properly playback MP3 files "gaplessly" probably has nothing to do with the music files themselves. Although MP3s are a form of compressed audio (just like M4As, WMAs, etc.), they can still be encoded to play gaplessly.

"Encoder delay" is the term for the number of silent samples added at the beginning of an audio file when it is encoded, and "encoder padding" is the term for the number of silent samples added at the end of an encoded audio file. If track 1 of the CD you just ripped onto your computer as an MP3 was encoded without padding and track 2 was encoded without delay, then the two tracks are able to be played gaplessly. Whether or not they are encoded in such a way depends on the encoder. For example, Windows Media Player encodes CBR (constant bit rate) MP3s without delay or padding, and so they can be played back gaplessly in iTunes (source: my 14:59 CD, by Sugar Ray, in which the last two tracks are meant to segue gaplessly). See this wiki section for some information about repairing badly delayed and/or padded MP3 files, as it will give you some insight about how audio files are encoded and decoded with regard to gapless playback.

So if your files are encoded to play gaplessly, they are encoded to play gaplessly. End of story. Putting them onto a different partition, or even onto a network drive, has absolutely no effect on whether or not the track can be played back gaplessly.

Now, whether or not the tracks actually are played back gaplessly has to do with how the music player buffers the audio samples and sends them to the audio interface (in Linux distributions, the most common audio interface is PulseAudio). If the music player is programmed poorly (which I'd say 99% of them are, unfortunately), it may not begin to read, decode and play the next track until the current track finishes, in which case there are many possible causes of delay, from thread context switching to bring the music player's thread into the foreground, to reading the first few frames of the audio file from the disk (which takes on the order of up to ten milliseconds for an HDD), to decoding those frames, to sending them down to the audio interface, to the audio interface sending them down to the sound library (usually ALSA, in Linux distributions), to the library sending them down to the kernel via a system get the idea. So it is up to the music player to be reading the frames of the next track before the current one ends so it can send them down to the audio interface in a gapless fashion.

In my experience, I have searched and searched for music players that actually play music files gaplessly (one of my favorite albums is Abbey Road, and the medley on side/disc 2 is destroyed when it's not gapless...), and sadly, most of the ones that report gapless playback (including RhythmBox and Banshee on Linux, Google Music, Samsung Music Player and countless others on Android, and various different ones for Windows) don't. The only two I've found that truly implement gapless playback correctly are iTunes on Windows, Mac, iPods, iPhones, etc. and GoneMAD Music Player on Android. If your music files do not play gaplessly in at least iTunes, then they were not encoded correctly, and you'll want to encode new ones from CDs or FLAC files you may have.

So, unfortunately, I do not know of any music players in Linux that actually do gapless playback. Maybe one of these days I'll look into the code of Banshee and see if there isn't anything I can do to help make it truly gapless...

Anyway, I hope this explanation helps a bit. If anyone else knows of some good music players that do gapless playback correctly, please comment.

share|improve this answer

It's not your hard disk. The problem is the software. Rhythmbox and Banshee both cannot do gapless playback even though they claim to. You might want to try another player like Audacious or Aqualung.

Gapless playback has been an issue on Linux ever since. Users have been asking for this to be default in a fresh Ubuntu install, but nothing happens. Developers simply don't like classical music or audiobooks. They only listen to chart crap and other popular music. And that's why gapless playback is rare on Linux. Because nerds don't have music taste.

share|improve this answer
That sounds hard to believe, especially since there is a checkbox that says "enable gapless playback." Also, neither Audacious or Aqualung seem to have very good library managment, which was the main reason I switched to Banshee. Do you have any other suggestions? – cg505 Oct 15 '12 at 0:40
While I don't agree with the "Nerds don't have music taste" idea, I really do have to wonder why developers that can make something as amazing as cmus or banshee, are too lazy to make a crossfading feature. Cause it's not hard to do. Fade one channel in, the other out, and have the second song start slightly before the first song ends. Guess I'll just have to manually mix songs I like until then... – B1KMusic Aug 25 '14 at 23:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.