Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I realize there are other questions like this one here, but I have visited them and tried several things and nothing is helping. One of them had a suggestion to boot the liveCD, and sudo mount /dev/sda* /mnt and to then chroot and reinstall grub. I did this and it did not help.

Then on the Windows side, I downloaded a free version of easyBCD and chose to add a Grub2 Ubuntu 12.04 entry. On restart I saw this entry, but when I click on it it takes me to a Windows failed to boot error, as if it wasn't even trying to boot Ubuntu.

I have booted from Ubuntu liveCD once again and have a snapshot of my GParted

gparted

I ran this bootinfoscript thing from the liveCD, here are my results: It seems grub is on sda. I just want to be able to boot into my Ubuntu on startup.

**Boot Info Script 0.61      [1 April 2012]**

============================= Boot Info Summary: ===============================

 => Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 
    1041658947 of the same hard drive for core.img. core.img is at this 
    location and looks for (,gpt7)/boot/grub on this drive.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 7: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/Boot/bootx64.efi

sda2: __________________________________________________________________________

    File system:       
    Boot sector type:  -
    Boot sector info: 
    Mounting failed:   mount: unknown filesystem type ''

sda3: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 7
    Boot files:        /bootmgr /Boot/BCD /Windows/System32/winload.exe

sda4: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda5: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /bootmgr /boot/bcd

sda6: __________________________________________________________________________

    File system:       BIOS Boot partition
    Boot sector type:  Grub2's core.img
    Boot sector info: 

sda7: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  Grub2 (v1.99)
    Boot sector info:  Grub2 (v1.99) is installed in the boot sector of sda7 
                       and looks at sector 1046637581 of the same hard drive 
                       for core.img. core.img is at this location and looks 
                       for (,gpt7)/boot/grub on this drive.
    Operating System:  Ubuntu 12.04 LTS
    Boot files:        /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

sda8: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

    Disk /dev/sda: 750.2 GB, 750156374016 bytes
    255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes

    Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

    /dev/sda1                   1 1,465,149,167 1,465,149,167  ee GPT


    GUID Partition Table detected.

    Partition    Start Sector    End Sector  # of Sectors System
    /dev/sda1           2,048       411,647       409,600 EFI System partition
    /dev/sda2         411,648       673,791       262,144 Microsoft Reserved Partition (Windows)
    /dev/sda3         673,792   533,630,975   532,957,184 Data partition (Windows/Linux)
    /dev/sda4     533,630,976 1,041,658,946   508,027,971 Data partition (Windows/Linux)
    /dev/sda5   1,412,718,592 1,465,147,391    52,428,800 Windows Recovery Environment (Windows)
    /dev/sda6   1,041,658,947 1,041,660,900         1,954 BIOS Boot partition
    /dev/sda7   1,041,660,901 1,396,174,572   354,513,672 Data partition (Windows/Linux)
    /dev/sda8   1,396,174,573 1,412,718,591    16,544,019 Swap partition (Linux)

blkid output:

________________________________________________________________

    Device           UUID                                   TYPE       LABEL

    /dev/loop0                                              squashfs   
    /dev/sda1        B498-319E                              vfat       SYSTEM
    /dev/sda3        820C0DA30C0D92F9                       ntfs       OS
    /dev/sda4        168410AB84108EFD                       ntfs       DATA
    /dev/sda5        AC7A43BA7A438056                       ntfs       Recovery
    /dev/sda7        42a5b598-4d8b-471b-987c-5ce8a0ce89a1   ext4       
    /dev/sda8        5732f1c7-fa51-45c3-96a4-7af3bff13278   swap       
    /dev/sr0                                                iso9660    Ubuntu 12.04 LTS i386

================================ Mount points: =================================

    Device           Mount_Point              Type       Options

    /dev/loop0       /rofs                    squashfs   (ro,noatime)
    /dev/sr0         /cdrom                   iso9660    (ro,noatime)

=========================== sda7/boot/grub/grub.cfg: ===========================

How can I get this option?

When I was using easyBCD, it kept saying I had no entries at all, so I did the add entry thing for Ubuntu many times and I see several of those on boot screen now. I'd love to get rid of all those unusable options.

share|improve this question
    
Your grub.cfg file is empty. Did you run sudo update-grub after chroot? –  Danatela Aug 12 '13 at 7:33
add comment

1 Answer 1

Your Windows is EFI type, so you need to convert Ubuntu in the same mode (EFI mode): see https://help.ubuntu.com/community/UEFI#Converting_Ubuntu_into_EFI_mode

share|improve this answer
    
But how can I do this from a liveCD? –  Palace Chan Sep 10 '12 at 22:54
    
You will need two tools (Boot-Repair and Gparted). Both are pre-installed in Ubuntu-Secure. So the easiest way is to burn a Ubuntu-Secure liveCD, boot on it, then follow the tutorial. –  LovinBuntu Sep 11 '12 at 7:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.