Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a computer with 2 operating systems dual booted: One is Windows 7 and the other is Ubuntu. My Ubuntu installation is installed within the Windows partition via wubi.exe.

I'm not using grubby, but windows 7's default bootloader. From within the windows settings i have set the time to choose the operating system to boot to zero, and as Ubuntu is at the top of the list, it boots automatically, not giving an option to load my windows 7 installation.

My problem is that I can not access my Windows 7 Operating System. It is essential to my work, so I am unable to remove this partition. Could someone give me a clue as to what to do?

share|improve this question

I found izx's answer here to be your best option.

If you aren't too comfortable editing these files there is an app called Grub Customizer which can modify a lot of grub settings. You can read more here - definitely worth a try.

Good luck!

share|improve this answer

You have to set the timeout in Windows BCD to a value >0

You can proceed either by

1) Running Windows 7 StartUp Repair which will reset timeout to 30 secs.

2) Edit BCD timeout -

run Windows 7 install/repair CD/DVD/USB and select repair->command prompt bcdedit /timeout 30 - to reset to default 30 secs

share|improve this answer

While it is the question if the inability to boot to windows is a disadvantage, you can edit the


file and change the line


after that you run

sudo update-grub
share|improve this answer
Don't you have to also run sudo update-grub to put that into effect? – John S Gruber Sep 9 '12 at 21:25
im not using grub, my ubuntu is installed within windows via the aplication thing from the website, i forget what its called – user88561 Sep 9 '12 at 21:39
If you do not use grub. Then you use the windows bootloader... This makes things a little different. I guess windows has a config file for that. I rememeber that pressing F8 was doing something, i think safe mode. Maybe that helps. – user61664 Sep 10 '12 at 6:40
Then you have installed Ubuntu INSIDE Windows (via the Wubi installer). In this case, the correct solution is to change the timeout in the Windows bootloader. See snayob's answer. – LovinBuntu Sep 10 '12 at 10:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.