Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an old CanoScan N640Pex flat bed scanner and a USB-to-parallel port cable through which I can connect it to my PC. Unfortunately neither Simple Scan nor XSane detect the scanner.

I'm running Ubuntu 12.04 (plus updates and backports) with kernel 3.2.0-31-generic.

dmesg tells me this when I plus the cable in:

[256411.641910] usb 7-1: new full-speed USB device number 10 using uhci_hcd
[256411.872392] usblp0: USB Bidirectional printer dev 10 if 0 alt 1 proto 2 vid 0x067B pid 0x2305
[256411.872417] usbcore: registered new interface driver usblp

lsusb shows this device for my cable:

Bus 007 Device 010: ID 067b:2305 Prolific Technology, Inc. PL2305 Parallel Port

The device node created is /dev/usb/lp0

crw-rw---- 1 root lp 180, 0 Sep  9 17:46 /dev/usb/lp0

There is no extra information from any of these commands when I attach the scanner to the cable and power it on, though.

I suspect I might need to change something in /etc/sane.d/canon_pp.conf, but I have no idea what to put for the ieee1284 line, since there is pretty much zero documentation for that parameter.

So how can I get it to work?

share|improve this question

It should work over parallel cable. Following this page:

Sane supported Scanners

You need the following two links and read them:

Needed driver:


Hope this helps. At least they say it is supported "good" but according to these pages only the Parallel Access might work.

share|improve this answer
Yes, I've seen all that. It's far too vague though. – detly Sep 9 '12 at 23:17
Have you tried the parallel port? Accoring to the "canon_pp.conf" which I found on my 12.04 the default setting is set to parport. And the settings should only changed here: "# Set a default initialisation mode for each port. Valid modes are: AUTO (attempts to automatically detect by trying both methods) # FB620P (10101010 style.. also works for FB320P) # FB630P (11001100 style.. also works for FB330P, N340P, N640P) init_mode AUTO parport0 # init_mode FB620P parport0 # init_mode FB630P parport0 – Peterling Sep 10 '12 at 15:13
I don't understand what you mean by "have you tried the parallel port". I have USB ports, and a USB-parallel cable. I've tried tweaking the settings in canon_pp.conf, but haven't found any combination that works. The ieee1284 parameter isn't actually documented anywhere, either. – detly Sep 10 '12 at 23:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.