Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I could use some help troubleshooting choppy streaming audio. The problem is jerky playback regardless of audio or video with audio. Both Chromium and Firefox have the problem, however files played directly on the machine with Rhythmbox sound just fine.

I'm running 12.04 LTS on a C2D T9300.

Most of the audio problems others ask about seem to be hardware related, so the following information might be relevant.

  sudo lshw -c multimedia
   description: Audio device
   product: 82801H (ICH8 Family) HD Audio Controller
   vendor: Intel Corporation
   physical id: 1b
   bus info: pci@0000:00:1b.0
   version: 03
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: driver=snd_hda_intel latency=0
   resources: irq:48 memory:f8400000-f8403fff
share|improve this question

Your issue sounds more like a bandwidth problem. If the streaming audio comes from an external broadcast you are limited by both your bandwidth and the broadcaster's bandwidth.

This usually occurs when you are attempting to gather a high bitrate broadcast. Have you tested the behaviour of your sound system when gathering information from a different place?

Buffering must also be considered, unfortunately the buffering itself can't be software controlled if the case is as of an internet radio-station and in certain cases you can allow the buffering by pausing the playback as mentioned in this Support answer by Google, related to "Buffering and Playback problems"

Do you mind providing any further information about the stream that is causing your issue in order to run a test? after which this answer may be edited to include the results of the testing.

Good luck!

share|improve this answer

I had this exact issue, try this, when your streaming video go to system settings (the gear with the wrench/screwdriver on it) click on the rightmost tab ("simultaneous output") and toggle the check box (it should be checked in the end) this is a temporary fix, of course. For some reason the software does not recognize this box being checked (ask a developer why) but after I did this the audio/video streamed perfectly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.